码迷,mamicode.com
首页 > 其他好文 > 详细

poj2845 01000001

时间:2015-02-18 09:37:05      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:poj

01000001
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10571   Accepted: 3345

Description

Adding binary numbers is a very simple task, and very similar to the longhand addition of decimal numbers. As with decimal numbers, you start by adding the bits (digits) one column at a time, from right to left. Unlike decimal addition, there is little to memorize in the way of rules for the addition of binary bits:

   0 + 0 = 0
   1 + 0 = 1
   0 + 1 = 1
   1 + 1 = 10
   1 + 1 + 1 = 11

Just as with decimal addition, when the sum in one column is a two-bit (two-digit) number, the least significant figure is written as part of the total sum and the most significant figure is“carried” to the next left column. Consider the following examples:

                       11  1 <-- Carry bits --> 1   11
  1001101             1001001                    1000111
+ 0010010           + 0011001                  + 1010110
 --------           ---------                  ---------
  1011111             1100010                   10011101

The addition problem on the left did not require any bits to be carried, since the sum of bits in each column was either 1 or 0, not 10 or 11. In the other two problems, there definitely were bits to be carried, but the process of addition is still quite simple.

Input

The first line of input contains an integer N, (1 ≤ N ≤ 1000), which is the number of binary addition problems that follow. Each problem appears on a single line containing two binary values separated by a single space character. The maximum length of each binary value is 80 bits (binary digits). Note: The maximum length result could be 81 bits (binary digits).

Output

For each binary addition problem, print the problem number, a space, and the binary result of the addition. Extra leading zeroes must be omitted.

Sample Input

3
1001101 10010
1001001 11001
1000111 1010110

Sample Output

1 1011111
2 1100010
3 10011101

java

参考代码:

import java.io.*;
import java.util.*;
import java.math.*;

public class Main {
    static public void main(String[] args)
    {
        Scanner cin = new Scanner(new BufferedInputStream(System.in));
        int t = cin.nextInt();
        for (int i = 0; i < t; i++)
        {
            String st1 = cin.next();
            String st2 = cin.next();
            BigInteger a = new BigInteger(st1, 2);
            BigInteger b = new BigInteger(st2, 2);
            System.out.println((i + 1) + " " + a.add(b).toString(2));
        }
    }
}



poj2845 01000001

标签:poj

原文地址:http://blog.csdn.net/codeforcer/article/details/43868425

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!