标签:hdu bestcoder 带权并查集 贪心
The Experience of Love
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 275 Accepted Submission(s): 111
Problem Description
A girl named Gorwin and a boy named Vivin is a couple. They arrived at a country named LOVE. The country consisting of
N
cities and only N?1
edges (just like a tree), every edge has a value means the distance of two cities. They select two cities to live,Gorwin living in a city and Vivin living in another. First date, Gorwin go to visit Vivin, she would write down the longest edge on this path(maxValue).Second
date, Vivin go to Gorwin, he would write down the shortest edge on this path(minValue),then calculate the result of maxValue subtracts minValue as the experience of love, and then reselect two cities to live and calculate new experience of love, repeat again
and again.
Please help them to calculate the sum of all experience of love after they have selected all cases.
Input
There will be about
5
cases in the input file.
For each test case the first line is a integer N,
Then follows n?1
lines, each line contains three integers a,
b,
and c,
indicating there is a edge connects city a
and city b
with distance c.
[Technical Specification]
1<N<=150000,1<=a,b<=n,1<=c<=109
Output
For each case,the output should occupies exactly one line. The output format is Case #x: answer, here x is the data number, answer is the sum of experience of love.
Sample Input
3
1 2 1
2 3 2
5
1 2 2
2 3 5
2 4 7
3 5 4
Sample Output
Case #1: 1
Case #2: 17
Hint
huge input,fast IO method is recommended.
In the first sample:
The maxValue is 1 and minValue is 1 when they select city 1 and city 2, the experience of love is 0.
The maxValue is 2 and minValue is 2 when they select city 2 and city 3, the experience of love is 0.
The maxValue is 2 and minValue is 1 when they select city 1 and city 3, the experience of love is 1.
so the sum of all experience is 1;
Source
Valentine‘s Day Round
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5176
题目大意:给一棵树,求任意{两点路径上的最大边权值-最小边权值}的总和。
题目分析:sigma(maxVal[i]?minVal[i])=sigma(maxVal)?sigma(minVal) ;所以我们分别求所有两点路径上的最大值的和,还有最小值的和。再相减就可以了。求最大值的和的方法用带权并查集,把边按权值从小到大排序,一条边一条边的算,当我们算第i 条边的时候权值为wi ,两点是ui,vi ,前面加入的边权值一定是小于等于当前wi 的,假设与ui 连通的点有a 个,与vi 连通的点有b 个,那么在a 个中选一个,在b 个中选一个,这两个点的路径上最大值一定是wi ,一共有a*b
个选法,爱情经验值为a*b*wi 。求最小值的和的方法类似。
#include <cstdio>
#include <algorithm>
#define ull unsigned long long
using namespace std;
int const MAX = 150005;
int fa[MAX], cnt[MAX], n;
ull ma, mi;
struct Edge
{
int u, v;
ull val;
}e[MAX];
bool cmp(Edge a, Edge b)
{
return a.val < b.val;
}
void init()
{
for(int i = 0; i <= n; i++)
{
fa[i] = i;
cnt[i] = 1;
}
}
int Find(int x)
{
return x == fa[x] ? x : fa[x] = Find(fa[x]);
}
int Union(int a, int b, ull val, bool flag)
{
int r1 = Find(a);
int r2 = Find(b);
if(flag)
ma += (ull)cnt[r1] * cnt[r2] * val;
else
mi += (ull)cnt[r1] * cnt[r2] * val;
fa[r1] = r2;
cnt[r2] += cnt[r1];
}
int main()
{
int ca = 1;
while(scanf("%d", &n) != EOF)
{
for(int i = 1; i <= n - 1; i++)
scanf("%d %d %llu", &e[i].u, &e[i].v, &e[i].val);
sort(e + 1, e + n, cmp);
init();
ma = 0;
for(int i = 1; i <= n - 1; i++)
Union(e[i].u, e[i].v, e[i].val, true);
init();
mi = 0;
for(int i = n - 1; i >= 1; i--)
Union(e[i].u, e[i].v, e[i].val, false);
printf("Case #%d: %llu\n", ca++, ma - mi);
}
}
HDU 5176 The Experience of Love (带权并查集 + 贪心)
标签:hdu bestcoder 带权并查集 贪心
原文地址:http://blog.csdn.net/tc_to_top/article/details/43876481