码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2680 Choose the best route 大年三十的首A 赤裸裸的Dijkstra 做这题需要一个小技巧

时间:2015-02-18 17:43:24      阅读:192      评论:0      收藏:0      [点我收藏+]

标签:hdu2680   最短路径   dijkstra   choose the best rout   

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8063    Accepted Submission(s): 2655


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
1 -1
 

尽管条件很艰苦,尽管今天是大年三十,我还是在努力。

这题如果直接Dijkstra的话,多次求单源最短路径,会超时,但是我只要设置一个超级源点0,0到各个起点的距离为0,到其他各点距离为INF。就完美解决了!是不是很巧妙

另外该图是无向图。自己到自己也是INF

下面是代码:

#include <stdio.h>
#include <string.h>
#define MAX 1010
#define INF 100000000
int dis[MAX] , graph[MAX][MAX] ;
bool closed[MAX] ;
void dijkstra(int u , int n)
{
	for(int i = 1 ; i <= n ; ++i)
	{
		dis[i] = graph[u][i] ;
		closed[i] = false ;
	}
	closed[u] = true ;
	for(int i = 1 ; i <= n ; ++i)
	{
		int min = INF , index = 0 ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(!closed[j] && dis[j]<min)
			{
				min = dis[j];
				index = j ;
			}
		}
		if(min == INF)
		{
			break ;
		}
		closed[index] = true ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(graph[index][j] == INF)
			{
				continue ; 
			}
			if(dis[j]>dis[index] + graph[index][j])
			{
				dis[j] = dis[index] + graph[index][j] ;
			}
		}
	}
}

int main()
{
	int n , m ,s; 
	while(~scanf("%d%d%d",&n,&m,&s))
	{
		for(int i = 0 ; i <= n ; ++i)
		{
			for(int j = 0 ; j <= i ; ++j)
			{
				graph[i][j] = graph[j][i] = INF ;
			}
		}
		for(int i = 0 ; i < m ; ++i)
		{
			int x,y,w;
			scanf("%d%d%d",&x,&y,&w);
			if(graph[x][y] > w)
			{
				graph[x][y] = w ;
			}
		}
		
		int ans = INF , q ;
		scanf("%d",&q) ;
		for(int i = 0 ; i < q ; ++i)
		{
			int u ;
			scanf("%d",&u);
			graph[0][u] = 0;
		}
		dijkstra(0,n) ;
		ans = ans<dis[s]?ans:dis[s] ;
		if(ans == INF)
		{
			puts("-1") ;
		}
		else
		{
			printf("%d\n",ans) ;
		}
	}
	return 0 ;
}

与君共勉

有志者,事竟成。破釜沉舟,百二秦关终属楚。             

苦心人,天不负。卧薪尝胆,三千越甲可吞吴。

hdu 2680 Choose the best route 大年三十的首A 赤裸裸的Dijkstra 做这题需要一个小技巧

标签:hdu2680   最短路径   dijkstra   choose the best rout   

原文地址:http://blog.csdn.net/lionel_d/article/details/43877169

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!