码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1535 Invitation Cards 大年初一首A 一次正向SPFA+一次逆向SPFA

时间:2015-02-19 18:41:30      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:hdu1535   最短路径   invitation cards   spfa   

Invitation Cards

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2311    Accepted Submission(s): 1125


Problem Description
In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.
The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where ‘X‘ denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.

 

Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.
 

Output
For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.
 

Sample Input
2 2 2 1 2 13 2 1 33 4 6 1 2 10 2 1 60 1 3 20 3 4 10 2 4 5 4 1 50
 

Sample Output
46 210
 
先是从1到其他结点来一次SPFA。然后是其他点分别到1来一次SPFA,可想而知,肯定超时,我们可以转换思路,由于终点都是1,那我们在反向建一个图,然后从1在到其他结点来一最短路,不就解决了吗

第一次用邻接表,代码写的比较渣。见谅:
#include <cstdio>
#include <queue>
#include <cstring>
#define MAX 1000100
#define INF 1500000000
using namespace std ;

struct Node{
	int to ;
	int w;
	int next ;
}edge[MAX],rev[MAX];

int head[MAX] ,revHead[MAX], cnt[MAX] , dis[MAX] ;
bool visited[MAX];

void init(int p , int q)
{
	memset(head,-1,sizeof(int)*(p+10)) ;
	memset(revHead,-1,sizeof(int)*(p+10)) ;
	for(int i = 1 ; i <= q ; ++i)
	{
		int x , y , w ;
		scanf("%d%d%d",&x,&y,&w) ;
		edge[i].to = y;
		edge[i].w = w ;
		edge[i].next = head[x];
		head[x] = i ;
		
		rev[i].to = x ;
		rev[i].w = w ;
		rev[i].next = revHead[y] ;
		revHead[y] = i ;
	}
}

bool SPFA(int h[] , Node e[], int s , int n)
{
	for(int i = 0 ; i <= n ; ++i )
	{
		dis[i] = INF;
		visited[i] = false ;
		cnt[i] = 0 ;
	}
	dis[s] = 0 ;
	visited[s] = true ;
	queue<int> que ;
	que.push(s) ;
	while(!que.empty())
	{
		int index = que.front() ;
		que.pop() ;
		++cnt[index] ;
		visited[index] = false ;
		if(cnt[index]>n)
		{
			return false ;
		}
		for(int i = h[index] ; i != -1 ; i = e[i].next)
		{
			if(dis[e[i].to]>dis[index]+e[i].w)
			{
				dis[e[i].to] = dis[index]+e[i].w ;
				if(!visited[e[i].to])
				{
					que.push(e[i].to);
					visited[e[i].to] = true ;
				}
			}
		}
	}
	return true ; 
}

int main()
{
	int p,q,n;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d",&p,&q);
		init(p,q);
		SPFA(head,edge,1,p);
		int sum = 0 ;
		for(int i = 2 ; i <= p ; ++i)
		{
			sum += dis[i];
		}
		SPFA(revHead,rev,1,p) ;
		for(int i = 2 ; i <= p ; ++i)
		{
			sum += dis[i];
		}
		printf("%d\n",sum) ;
	}
	return 0 ;
}

与君共勉

hdu 1535 Invitation Cards 大年初一首A 一次正向SPFA+一次逆向SPFA

标签:hdu1535   最短路径   invitation cards   spfa   

原文地址:http://blog.csdn.net/lionel_d/article/details/43883071

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!