码迷,mamicode.com
首页 > 其他好文 > 详细

UVALive - 3026 - Period (KMP)

时间:2015-02-20 09:45:52      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:acm   kmp   

UVALive - 3026

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

技术分享

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 ≤ N ≤ 1 000 000) ? the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output

For each test case, output ?Test case #? and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source







AC代码(还有点纠结):

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;

const int maxn = 1000005;
char str[maxn];
int next[maxn];

int main() {
	int n, cas = 1;
	while(scanf("%d", &n) == 1 && n) {
		scanf("%s", str);
		next[0] = 0, next[1] = 0;
		for(int i = 1; i < n; i++) {
			int j = next[i];
			while(j && str[i] != str[j]) j = next[j];
			next[i+1] = (str[i] == str[j] ? j+1 : 0);
		}
		
		printf("Test case #%d\n", cas++);
		for(int i = 2; i <= n; i++)
			if(next[i] > 0 && i % ( i - next[i] ) == 0) 
				printf("%d %d\n", i, i / (i - next[i]));
		printf("\n");
	}
	return 0;
} 








UVALive - 3026 - Period (KMP)

标签:acm   kmp   

原文地址:http://blog.csdn.net/u014355480/article/details/43887625

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!