码迷,mamicode.com
首页 > 其他好文 > 详细

杭电ACM 三 大数取模

时间:2015-02-20 14:09:40      阅读:345      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   大一练习   杭电   

题目及代码

Problem Description

As we know, Big Number is always troublesome. But it‘s really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.

Input

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.

Output

For each test case, you have to ouput the result of A mod B.

Sample Input

2 3
12 7
152455856554521 3250

Sample Output

2
5
1521
/*
*Copyright (c)2014,烟台大学计算机与控制工程学院
*All rights reserved.
*文件名称:mod.cpp
*作    者:冷基栋
*完成日期:2015年2月20日
*版 本 号:v1.0
*/
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    char str[100000];
    int s,l,b,i;
    while(cin>>str>>s)
    {
        l=strlen(str);
        b=0;
        for(i=0;i<l;i++)
        b=(b*10+(str[i]-'0')%s)%s;
        cout<<b<<endl;
    }
    return 0;
}

运行结果:

技术分享

知识点总结:

在做题之前,先了解这样一些结论:

A*B % C = (A%C * B%C)%C
(A+B)%C = (A%C + B%C)%C
如 532 mod 7 =(500%7+30%7+2%7)%7;
当然还有a*b mod c=(a mod c+b mod c)mod c;
如35 mod 3=((5%3)*(7%3))%3
   有了这一些结论,题目就好做了!

学习心得:

好好学习 天天向上







杭电ACM 三 大数取模

标签:acm   c++   大一练习   杭电   

原文地址:http://blog.csdn.net/ljd939952281/article/details/43888675

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!