码迷,mamicode.com
首页 > 其他好文 > 详细

UVa1584 Circular Sequence

时间:2015-02-21 00:13:11      阅读:252      评论:0      收藏:0      [点我收藏+]

标签:

Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence ``CGAGTCAGCT", that is, the last symbol ``T" in ``CGAGTCAGCT" is connected to the first symbol ``C". We always read a circular sequence in the clockwise direction.

技术分享

Since it is not easy to store a circular sequence in a computer as it is, we decided to store it as a linear sequence. However, there can be many linear sequences that are obtained from a circular sequence by cutting any place of the circular sequence. Hence, we also decided to store the linear sequence that is lexicographically smallest among all linear sequences that can be obtained from a circular sequence.

Your task is to find the lexicographically smallest sequence from a given circular sequence. For the example in the figure, the lexicographically smallest sequence is ``AGCTCGAGTC". If there are two or more linear sequences that are lexicographically smallest, you are to find any one of them (in fact, they are the same).

Input 

The input consists of T test cases. The number of test cases T is given on the first line of the input file. Each test case takes one line containing a circular sequence that is written as an arbitrary linear sequence. Since the circular sequences are DNA sequences, only four symbols, A, C, G and T, are allowed. Each sequence has length at least 2 and at most 100.

Output 

Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence for the test case.

The following shows sample input and output for two test cases.

Sample Input 

2                                     
CGAGTCAGCT                            
CTCC

Sample Output 

AGCTCGAGTC 
CCCT

这道题很简单,只需要写一个比较字符串大小的函数,然后枚举每一个位置得出最小值即可。

下面给出代码:

#include <stdio.h>
#include <string.h>
#define MAXN 105

int less(const char* s, int p, int q)
{
  int n = strlen(s);
  for(int i = 0; i < n; i++)
    if(s[(p+i)%n] != s[(q+i)%n])
      return s[(p+i)%n] < s[(q+i)%n];
  return 0;
}

int main()
{
  int T;
  char s[MAXN];
  scanf("%d", &T);
  while(T--)
  {
    scanf("%s", s);
    int ans = 0;
    int n = strlen(s);
    for(int i = 1; i < n; i++)
    if(less(s, i, ans)) ans = i;
      for(int i = 0; i < n; i++)
        putchar(s[(i+ans)%n]);
    putchar(\n);
}
  return 0;
}
本题注意的知识点就是字符串大小比较方法和使用%运算符处理循环串问题的技巧。

UVa1584 Circular Sequence

标签:

原文地址:http://www.cnblogs.com/cuichen/p/4296773.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!