码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3311 Hie with the Pie (Floyd + 状压dp 简单TSP问题)

时间:2015-02-21 06:32:15      阅读:212      评论:0      收藏:0      [点我收藏+]

标签:poj   状压dp   floyd   tsp   

Hie with the Pie
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 5019   Accepted: 2673

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

Source


题目链接:http://poj.org/problem?id=3311


题目大意:一个人要送n份货,给出一个矩阵,表示任意两个点间的直接路径的时间,求从起点0送完这n份货(到达指定的n个地点)再回到起点0的最短时间


题目分析:n不大,可以进行状态压缩,首先用Floyd处理一下任意两点的最短路,dp[i][j]表示在状态i的条件下到城市j的最短时间,显然如果i == (1 << (j - 1)),表示从只经过城市j,这时候dp[i][j] = dis[0][j],否则就是要经过别的城市到达j,这里枚举当前状态下经过的除了j的其他城市,注意一定是当前状态下,这里类似Floyd,最后dp[(1 << n) - 1][i]表示经过了所有店到达i我们只要枚举dp[(1 << n) - 1][i] + dis[i][0]的最小值即可


#include <cstdio>
#include <algorithm>
using namespace std;
int const INF = 0xfffffff;
int dp[(1 << 11)][11], n;
int dis[11][11];

void Floyd()
{
    for(int k = 0; k <= n; k++)
        for(int i = 0; i <= n; i++)
            for(int j = 0; j <= n; j++)
                if(dis[i][j] > dis[i][k] + dis[k][j])
                    dis[i][j] = dis[i][k] + dis[k][j];
}

int main()
{
    while(scanf("%d", &n) != EOF && n)
    {
        for(int i = 0; i <= n; i++)
            for(int j = 0; j <= n; j++)
                scanf("%d", &dis[i][j]);
        Floyd();
        for(int i = 0; i <= (1 << n) - 1; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                if(i == (1 << (j - 1)))
                    dp[i][j] = dis[0][j];
                else
                {
                    dp[i][j] = INF;
                    for(int k = 1; k <= n; k++)
                        if((k != j) && (i & (1 << (k - 1)))) //当前状态下
                            dp[i][j] = min(dp[i][j], dp[i ^ (1 << (j - 1))][k] + dis[k][j]);
                }   
            }
        }
        int ans = dp[(1 << n) - 1][1] + dis[1][0];
        for(int i = 2; i <= n; i++)
            ans = min(ans, dp[(1 << n) - 1][i] + dis[i][0]);
        printf("%d\n", ans);
    }
}


POJ 3311 Hie with the Pie (Floyd + 状压dp 简单TSP问题)

标签:poj   状压dp   floyd   tsp   

原文地址:http://blog.csdn.net/tc_to_top/article/details/43894747

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!