码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1426-Find The Multiple(bfs)

时间:2015-02-21 09:47:09      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:

Find The Multiple
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 19272   Accepted: 7813   Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111
题意:给一个数n,求其只含有数字0或1的倍数,输出其任意的可行解(答案不唯一

思路:从1开始判断是否为n的倍数,然后乘10或者乘10加1,找到一个退出即可

Ps:要不是这道题在bfs里我都不知道怎么搞。这个题我也不知道怎么回事,用g++交AC,用c++交MLE,saddd

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>

using namespace std;
long long n;
queue<long long >q;
long long bfs()
{
    long long res;
    while(!q.empty())
        q.pop();
    q.push(1);
    while(!q.empty()){
        res=q.front();
        q.pop();
        if(res%n==0)
            return res;
        q.push(res*10);
        q.push(res*10+1);
    }
}
int main()
{
    while(~scanf("%lld",&n)){
        if(n==0) break;
        printf("%lld\n",bfs());
    }
    return 0;
}


POJ 1426-Find The Multiple(bfs)

标签:

原文地址:http://blog.csdn.net/u013486414/article/details/43889387

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!