码迷,mamicode.com
首页 > 其他好文 > 详细

POJ - 2406 - Power Strings (KMP)

时间:2015-02-22 11:07:27      阅读:126      评论:0      收藏:0      [点我收藏+]

标签:acm   poj   kmp   

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 34601   Accepted: 14319

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source






AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std; 

char str[1000005];
int next[1000005];

int main() {
	while(scanf("%s", str) && str[0] != '.') {
		int i = 0, j = -1, len = strlen(str);
		next[0] = -1;
		while(i < len) {
			if(j == -1 || str[i] == str[j]) next[++i] = ++j;
			else j = next[j];
		}
		
		if(len % (len - next[len]) == 0) printf("%d\n", len / (len - next[len]));
		else printf("1\n");
	}
	return 0;
}











POJ - 2406 - Power Strings (KMP)

标签:acm   poj   kmp   

原文地址:http://blog.csdn.net/u014355480/article/details/43899389

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!