码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ(1013) ——Digital Roots(字符串模拟题)

时间:2015-02-22 11:07:30      阅读:116      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output
For each integer in the input, output its digital root on a separate line of the output.
Sample Input
24 39 0
Sample Output
6
3

 

这道题说到底就是要注意可能它给的数字会很大,所以不能用int或是__int64来储存,要用字符串才行。

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int main(){
    char a[1000],b[1000];
    int i,j,k,l,ans,t;
    while(scanf("%s",a)!=EOF){
        if(a[0]=='0')  break;
        l=strlen(a); 
        strcpy(b,a); 
        while(1){
            ans=0;
            for(i=0;i<l;i++){
                ans+=b[i]-'0';
            }
            if(ans>9) {
                for(i=0;ans!=0;i++){
                    b[i]=(ans%10)+'0';
                    ans=ans/10;
                }
                b[i]='\0';
            }
            else break;
            l=strlen(b);
        }
        printf("%d\n",ans);
    }
}


 

HDOJ(1013) ——Digital Roots(字符串模拟题)

标签:

原文地址:http://blog.csdn.net/acmer_hades/article/details/43899081

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!