码迷,mamicode.com
首页 > 其他好文 > 详细

hdu3709 数位dp(自身平衡的数字)

时间:2015-02-22 23:06:28      阅读:194      评论:0      收藏:0      [点我收藏+]

标签:

http://acm.hdu.edu.cn/showproblem.php?pid=3709

Problem Description
A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It‘s your job
to calculate the number of balanced numbers in a given range [x, y].
 

Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 1018).
 

Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
 

Sample Input
2 0 9 7604 24324
 

Sample Output
10 897

/**
hdu 3709   数位dp(自身平衡的数字)
题目大意:求给定区间内满足自身平衡的数的个数,所谓平衡,
          比如:4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively.
解题思路:枚举支点。dp[i][j][k] i表示处理到的数位,j是支点,k是力矩和。但是要要把全是0的数排除
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long LL;

LL dp[20][20][2000];
int bit[25];

LL dfs(int pos,int level,int presum,int flag)
{
    if(pos==-1)return presum==0;
    if(presum<0)return 0;
    if(!flag&&dp[pos][level][presum]!=-1)
        return dp[pos][level][presum];
    int end=flag?bit[pos]:9;
    LL ans=0;
    for(int i=0; i<=end; i++)
    {
        ans+=dfs(pos-1,level,presum+(pos-level)*i,flag&&(i==end));
    }
    if(!flag)dp[pos][level][presum]=ans;
    return ans;
}

LL solve(LL n)
{
    int len=0;
    while(n)
    {
        bit[len++]=n%10;
        n/=10;
    }
    LL ans=0;
    for(int i=0; i<len; i++)
    {
        ans+=dfs(len-1,i,0,1);
    }
    return ans-(len-1);///去掉全部为0的情况
}
int main()
{
    int T;
    LL l,r;
    memset(dp,-1,sizeof(dp));
    scanf("%d",&T);
    while(T--)
    {
        scanf("%I64d%I64d",&l,&r);
        printf("%I64d\n",solve(r)-solve(l-1));
    }
    return 0;
}


hdu3709 数位dp(自身平衡的数字)

标签:

原文地址:http://blog.csdn.net/lvshubao1314/article/details/43910299

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!