码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3661 Running(区间dp)

时间:2015-02-23 09:44:37      阅读:231      评论:0      收藏:0      [点我收藏+]

标签:区间dp

Language:
Running
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5300   Accepted: 1974

Description

The cows are trying to become better athletes, so Bessie is running on a track for exactly N (1 ≤ N ≤ 10,000) minutes. During each minute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though, depends on her ‘exhaustion factor‘, which starts at 0. When she chooses to run in minute i, she will run exactly a distance of Di (1 ≤ Di ≤ 1,000) and her exhaustion factor will increase by 1 -- but must never be allowed to exceed M (1 ≤ M ≤ 500). If she chooses to rest, her exhaustion factor will decrease by 1 for each minute she rests. She cannot commence running again until her exhaustion factor reaches 0. At that point, she can choose to run or rest.

At the end of the N minute workout, Bessie‘s exaustion factor must be exactly 0, or she will not have enough energy left for the rest of the day.

Find the maximal distance Bessie can run.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 contains the single integer: Di

Output

* Line 1: A single integer representing the largest distance Bessie can run while satisfying the conditions.
 

Sample Input

5 2
5
3
4
2
10

Sample Output

9

Source



dp[i][j]表示 i 时刻 j 的疲劳度走的最远距离


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

#define N 10005

int dp[N][505],n,m,a[N];

int main()
{
	int i,j;
	while(~scanf("%d%d",&n,&m))
	{
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);

		memset(dp,0,sizeof(dp));
		
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=m;j++)
				dp[i][j]=dp[i-1][j-1]+a[i];

            dp[i][0]=dp[i-1][0];

			for(int k=1;k<=m&&i>=k;k++)
				dp[i][0]=max(dp[i][0],dp[i-k][k]);
		}
		printf("%d\n",dp[n][0]);
	}
	return 0;
}




POJ 3661 Running(区间dp)

标签:区间dp

原文地址:http://blog.csdn.net/u014737310/article/details/43908619

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!