标签:hdu4463 outlets 次小生成树 prim
Outlets
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2200 Accepted Submission(s): 1028
Problem Description
In China, foreign brand commodities are often much more expensive than abroad. The main reason is that we Chinese people tend to think foreign things are better and we are willing to pay much for them. The typical example is, on the
United Airline flight, they give you Haagendazs ice cream for free, but in China, you will pay $10 to buy just a little cup.
So when we Chinese go abroad, one of our most favorite activities is shopping in outlets. Some people buy tens of famous brand shoes and bags one time. In Las Vegas, the existing outlets can‘t match the demand of Chinese. So they want to build a new outlets
in the desert. The new outlets consists of many stores. All stores are connected by roads. They want to minimize the total road length. The owner of the outlets just hired a data mining expert, and the expert told him that Nike store and Apple store must be
directly connected by a road. Now please help him figure out how to minimize the total road length under this condition. A store can be considered as a point and a road is a line segment connecting two stores.
Input
There are several test cases. For each test case: The first line is an integer N( 3 <= N <= 50) , meaning there are N stores in the outlets. These N stores are numbered from 1 to N. The second line contains two integers p and q, indicating
that the No. p store is a Nike store and the No. q store is an Apple store. Then N lines follow. The i-th line describes the position of the i-th store. The store position is represented by two integers x,y( -100<= x,y <= 100) , meaning that the coordinate
of the store is (x,y). These N stores are all located at different place. The input ends by N = 0.
Output
For each test case, print the minimum total road length. The result should be rounded to 2 digits after decimal point.
Sample Input
4
2 3
0 0
1 0
0 -1
1 -1
0
Sample Output
转载请申明博客原地址:http://blog.csdn.net/lionel_d
数据范围小。水的不能再水,没什么可说的,就是次小生成树
#include <stdio.h>
#include <string.h>
#include <cmath>
#define MAX 60
const double INF = 1000000000.0 ;
struct Point{
int x,y;
}p[MAX];
double graph[MAX][MAX] ,max[MAX][MAX] ;
bool used[MAX][MAX] , visited[MAX];
double prim(int n)
{
int closest[MAX];
double lowCost[MAX] , sum = 0.0;
memset(visited,false,sizeof(visited)) ;
memset(max,0,sizeof(max)) ;
memset(used,false,sizeof(used)) ;
for(int i = 1 ; i <= n ; ++i)
{
lowCost[i] = graph[1][i] ;
closest[i] = 1 ;
}
visited[1] = true ;
for(int i = 0 ; i < n-1 ; ++i)
{
double min = INF ;
int index = -1 ;
for(int j = 1 ; j <= n ; ++j)
{
if(!visited[j] && lowCost[j]<min)
{
min = lowCost[j];
index = j ;
}
}
if(index == -1)
{
break ;
}
sum += lowCost[index] ;
visited[index] = true ;
used[index][closest[index]] = used[closest[index]][index] = true ;
for(int j = 1 ; j <= n ; ++j)
{
if(visited[j] && j != index)
{
max[j][index] = max[index][j] = lowCost[index]>max[j][closest[index]]?lowCost[index]:max[j][closest[index]] ;
}
if(!visited[j] && lowCost[j]>graph[index][j])
{
lowCost[j] = graph[index][j] ;
closest[j] = index ;
}
}
}
return sum ;
}
double dis(const Point &p1 , const Point &p2)
{
int x = p1.x-p2.x , y = p1.y-p2.y ;
return sqrt((x*x+y*y)*1.0) ;
}
int main()
{
int n ;
while(~scanf("%d",&n) && n)
{
Point p[MAX] ;
int pt,qt;
scanf("%d%d",&pt,&qt);
for(int i = 1 ; i <= n ; ++i)
{
scanf("%d%d",&p[i].x,&p[i].y) ;
}
for(int i = 1 ; i <= n ; ++i)
{
graph[i][i] = 0 ;
for(int j = 1 ; j < i ; ++j)
{
graph[i][j] = graph[j][i] = dis(p[i],p[j]) ;
}
}
double sum = prim(n) ;
if(used[pt][qt])
{
printf("%.2lf\n",sum) ;
}
else
{
printf("%.2lf\n",sum+graph[pt][qt]-max[pt][qt]) ;
}
}
return 0 ;
}
与君共勉hdu 4463 Outlets Prim 次小生成树 简单题
标签:hdu4463 outlets 次小生成树 prim
原文地址:http://blog.csdn.net/lionel_d/article/details/43915839