码迷,mamicode.com
首页 > 其他好文 > 详细

NYOJ 698 A Coin Problem (斐波那契)

时间:2015-02-23 23:44:15      阅读:396      评论:0      收藏:0      [点我收藏+]

标签:斐波那契

链接:click here

题意:

描述
One day,Jiameier is tidying up the room,and find some coins. Then she throws the coin to play.Suddenly,she thinks of a problem ,that if throw n times coin ,how many situations of no-continuous up of the coin. Hey,Let‘s solve the problem.
输入
The first of input is an integer T which stands for the number of test cases. For each test case, there is one integer n (1<=n<=1000000000) in a line, indicate the times of throwing coins.
输出
The number of all situations of no-continuous up of the coin, moduled by 10000.
样例输入
3
1
2
3
样例输出
2
3
5
来源
SCU Programming Contest 2011 Preliminary
思路:大数的斐波那契。

代码:

#include <stdio.h>
int main()
{
    int i;
    int a[15010];
    a[0]=0,a[1]=2,a[2]=3;
    for(i=3;i<15010;i++)
        a[i]=(a[i-1]+a[i-2])%10000;
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int m;
        scanf("%d",&m);
        printf("%d\n",a[m%15000]%10000);
    }
    return 0;
}
When you want to give up, think of why you persist until now!

NYOJ 698 A Coin Problem (斐波那契)

标签:斐波那契

原文地址:http://blog.csdn.net/u013050857/article/details/43919257

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!