码迷,mamicode.com
首页 > 其他好文 > 详细

YT14-HDU-在0-100间找到那个正确的x

时间:2015-02-25 13:02:42      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:c++   iostream   namespace   编程   二分查找   

Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

代码如下:

#include <iostream>
#include <cmath>
#include <iomanip>
using namespace std;
double Y;
double Equ(double x)
{
    return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;             //判断是否等式是否相等
}

double Search()                                               //二分查找
{
    double high=100,low=0;
    double temp;
    while (high-low>1e-6)
    {
        temp=(low+high)/2;
        if (Equ(temp)<Y)
            low=temp+1e-7;
        else
            high=temp-1e-7;
    }
    return (high+low)/2.0;
}

int main()
{
    int T;
    cin>>T;
    while (T--)
    {
        cin>>Y;
        if (Equ(0)<=Y&&Equ(100)>=Y)                    //如果满足条件,说明0到100中间肯定存在一个值使得Equ(x)=Y
            cout<<setiosflags(ios::fixed)<<setprecision(4)<<Search()<<endl;
        else
            cout<<"No solution!"<<endl;
    }
    return 0;
}


解题思路:

题目大意是在0到100间找到满足 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y 的那个x。

简单的二分查找,重点是计算精度和输出格式。




YT14-HDU-在0-100间找到那个正确的x

标签:c++   iostream   namespace   编程   二分查找   

原文地址:http://blog.csdn.net/liuchang54/article/details/43935825

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!