码迷,mamicode.com
首页 > 其他好文 > 详细

1015. Reversible Primes (20)

时间:2015-02-25 21:10:58      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:c++   pat   

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 22
3 10
-2
Sample Output:
Yes
Yes
No

#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;

bool isPrime(int x) {
    if(x < 2) {
        return false;
    }
    if(x == 2 || x == 3) {
        return true;
    }
    for(int i=2; i*i<=x; i++) {
        if(x % i == 0) {
            return false;
        }
    }
    return true;
}

int main() {
    int n, d;
    while(cin>>n) {
        if(n < 0) {
            break;
        } else {
            cin>>d;
            if(isPrime(n)) {
                queue<int> q;
                while(n!=0) {
                    q.push(n%d);
                    n /= d;
                }
                int reverse = 0;
                while(!q.empty()) {
                    reverse=reverse*d;
                    reverse=reverse+q.front();
                    q.pop();
                }
                if(isPrime(reverse)) {
                    cout<<"Yes"<<endl;
                } else {
                    cout<<"No"<<endl;
                }
            } else {
                cout<<"No"<<endl;
            }
        }
    }
    return 0;
}

1015. Reversible Primes (20)

标签:c++   pat   

原文地址:http://blog.csdn.net/jason_wang1989/article/details/43939871

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!