码迷,mamicode.com
首页 > 其他好文 > 详细

1012. The Best Rank (25)

时间:2015-02-25 21:10:23      阅读:157      评论:0      收藏:0      [点我收藏+]

标签:c++   pat   

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A

N/A

#include <iostream>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;

struct student {
    int id;
    int C;
    int M;
    int E;
    int A;
};

bool sortByC(const student& a, const student& b) {
    return a.C > b.C;
}

bool sortByM(const student& a, const student& b) {
    return a.M > b.M;
}

bool sortByE(const student& a, const student& b) {
    return a.E > b.E;
}

bool sortByA(const student& a, const student& b) {
    return a.A > b.A;
}

int main() {
    vector<student> v;
    map<int, char> mType;
    map<int, int> mRank;
    int n, m, q;
    cin>>n>>m;
    for(int i=0; i<n; i++) {
        struct student s;
        cin>>s.id>>s.C>>s.M>>s.E;
        s.A = (s.C + s.M + s.E) / 3;
        v.push_back(s);
    }

    int score = -1;
    int rank = 0;
    sort(v.begin(), v.end(), sortByA);
    for(int i=0; i<v.size(); i++) {
        if(v[i].A != score) {
            rank = i+1;
        }
        score = v[i].A;
        mRank[v[i].id] = rank;
        mType[v[i].id] = 'A';
    }

    score = -1;
    rank = 0;
    sort(v.begin(), v.end(), sortByC);
    for(int i=0; i<v.size(); i++) {
        if(v[i].C != score) {
            rank = i+1;
        }
        score = v[i].C;

        if(mRank[v[i].id]>rank) {
            mRank[v[i].id] = rank;
            mType[v[i].id] = 'C';
        }
    }

    score = -1;
    rank = 0;
    sort(v.begin(), v.end(), sortByM);
    for(int i=0; i<v.size(); i++) {
        if(v[i].M != score) {
            rank = i+1;
        }
        score = v[i].M;

        if(mRank[v[i].id]>rank) {
            mRank[v[i].id] = rank;
            mType[v[i].id] = 'M';
        }
    }

    score = -1;
    rank = 0;
    sort(v.begin(), v.end(), sortByE);
    for(int i=0; i<v.size(); i++) {
        if(v[i].E != score) {
            rank = i+1;
        }
        score = v[i].E;

        if(mRank[v[i].id]>rank) {
            mRank[v[i].id] = rank;
            mType[v[i].id] = 'E';
        }
    }

    for(int i=0;i<m;i++) {
        cin>>q;
        if(mType.count(q))
            cout<<mRank[q]<<" "<<mType[q]<<endl;
        else
            cout<<"N/A"<<endl;
    }
}


1012. The Best Rank (25)

标签:c++   pat   

原文地址:http://blog.csdn.net/jason_wang1989/article/details/43939841

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!