码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3853 LOOPS (概率dp)

时间:2015-02-25 22:25:02      阅读:289      评论:0      收藏:0      [点我收藏+]

标签:hdu   概率dp   


LOOPS

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)

Total Submission(s): 2931    Accepted Submission(s): 1209

Problem Description
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.
技术分享

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.



Input
The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF


Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

 
Sample Input
2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
 
Sample Output
6.000
 
Source
2011 Invitational Contest Host by BUPT

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3853

题目大意:一个r*c的迷宫,每个位置有三个分别为传送到grid (r, c), grid (r, c+1), grid (r+1, c)的概率,每次要花2魔法值,求从起点(1, 1)到终点(r, c)魔法值的期望

题目分析:简单的概率dp,用p[0][i][j],p[1][i][j],p[2][i][j]分别表示每个点的三个对应概率,dp[i][j]表示从(i,j)到(r,c)魔法值的期望,则可得到转移方程:
dp[i][j]=dp[i][j] * p[0][i][j] + dp[i][j + 1] * p[1][i][j] + dp[i + 1][j] * p[2][i][j] 
==> dp[i][j] = (dp[i][j + 1] * p[1][i][j] + dp[i + 1][j] * p[2][i][j]) / (1.0 - p[0][i][j])
从这个转移方程不难看出从dp[r][c]向前推就行了,dp[r][c] = 0,还有要注意分母为0的情况要特判,如果p[0][i][j] = 1,则显然是个死循环,dp[i][j] = 0

 

#include <cstdio>
#include <cmath>
int const MAX = 1005;
double const EPS = 1e-10;
double p[3][MAX][MAX], dp[MAX][MAX];

int main()
{
    int r, c;
    double p1, p2, p3;
    while(scanf("%d %d", &r, &c) != EOF)
    {
        for(int i = 1; i <= r; i++)
            for(int j = 1; j <= c; j++)
                scanf("%lf %lf %lf", &p[0][i][j], &p[1][i][j], &p[2][i][j]);
        dp[r][c] = 0;
        for(int i = r; i >= 1; i--)
            for(int j = c; j >= 1; j--)
                if(!(i == r && j == c))
                    if(fabs(p[0][i][j] - 1.0) < EPS)
                        dp[i][j] = 0;
                    else 
                        dp[i][j] = (dp[i][j + 1] * p[1][i][j] + dp[i + 1][j] * p[2][i][j] + 2) / (1.0 - p[0][i][j]);
        printf("%.3f\n", dp[1][1]);
    }
}


HDU 3853 LOOPS (概率dp)

标签:hdu   概率dp   

原文地址:http://blog.csdn.net/tc_to_top/article/details/43940361

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!