码迷,mamicode.com
首页 > 其他好文 > 详细

hdu2196Computer(树形dp)

时间:2015-02-26 10:03:12      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:树形dp

A school bought the first computer some time ago(so this computer‘s id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.
技术分享


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
5 1 1 2 1 3 1 1 1
 

Sample Output
3 2 3 4 4
 

其实就是 递归的应用,不够看别人思路挺新颖的

  http://www.cnblogs.com/kuangbin/archive/2012/08/28/2659915.html


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;

using namespace std;

#define N 10005

int head[N],num,n;
int big[N],small[N];
int bigid[N],smallid[N];

struct stud{
  int to,len;
  int next;
}e[N*2];

inline void add(int s,int to,int len)
{
	e[num].to=to;
	e[num].len=len;
	e[num].next=head[s];
	head[s]=num++;
}

void dfs1(int x,int father)
{
	  big[x]=small[x]=0;
	  int i;
	  for(i=head[x];i!=-1;i=e[i].next)
	  {
		  int to=e[i].to;
	  	  if(to==father) continue;
	  	  dfs1(to,x);
	  	  if(big[to]+e[i].len>small[x])
		  {
		  	 small[x]=big[to]+e[i].len;
		  	 smallid[x]=to;
		  	 if(small[x]>big[x])
			 {
			 	swap(small[x],big[x]);
			 	swap(smallid[x],bigid[x]);
			 }
		  }
	  }
}

void dfs2(int x,int father)
{
    int i;
    for(i=head[x];i!=-1;i=e[i].next)
	{
		int to=e[i].to;
		if(to==father) continue;

		if(bigid[x]==to)
		{
			if(small[x]+e[i].len>small[to])
			{
				small[to]=small[x]+e[i].len;
				smallid[to]=x;
				if(small[to]>big[to])
				{
					swap(big[to],small[to]);
					swap(bigid[to],smallid[to]);
				}
			}
		}
		else
		{
			if(big[x]+e[i].len>small[to])
			{
				small[to]=big[x]+e[i].len;
				smallid[to]=x;
				if(small[to]>big[to])
				{
					swap(big[to],small[to]);
					swap(bigid[to],smallid[to]);
				}
			}
		}
		dfs2(to,x);
	}
}

int main()
{
	int i,j;
	while(~scanf("%d",&n))
	{
		memset(head,-1,sizeof(head));
		int len,to;
		num=0;
		for(i=2;i<=n;i++)
		{
			scanf("%d%d",&to,&len);
			add(i,to,len);
			add(to,i,len);
		}

		dfs1(1,-1);
		dfs2(1,-1);

		for(i=1;i<=n;i++)
			printf("%d\n",big[i]);
	}
	return 0;
}




hdu2196Computer(树形dp)

标签:树形dp

原文地址:http://blog.csdn.net/u014737310/article/details/43940313

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!