码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1536 S-Nim 博弈论,,求出SG'函数就可以解决

时间:2015-02-26 23:05:36      阅读:422      评论:0      收藏:0      [点我收藏+]

标签:hdu1536   s-nim   sg函数   博弈论   公平组合博弈   

S-Nim

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4975    Accepted Submission(s): 2141


Problem Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:


  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

  The players take turns chosing a heap and removing a positive number of beads from it.

  The first player not able to make a move, loses.


Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:


  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

  If the xor-sum is 0, too bad, you will lose.

  Otherwise, move such that the xor-sum becomes 0. This is always possible.


It is quite easy to convince oneself that this works. Consider these facts:

  The player that takes the last bead wins.

  After the winning player‘s last move the xor-sum will be 0.

  The xor-sum will change after every move.


Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
 

Input
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.
 

Output
For each position: If the described position is a winning position print a ‘W‘.If the described position is a losing position print an ‘L‘. Print a newline after each test case.
 

Sample Input
2 2 5 3 2 5 12 3 2 4 7 4 2 3 7 12 5 1 2 3 4 5 3 2 5 12 3 2 4 7 4 2 3 7 12 0
 

Sample Output
LWW WWL
 

这道题的题目挺长的,大致就说,给定一个s集合,每次 行走的步数属于s集合,,,共有n堆石子,问首先出手的能否必胜


话说看了好久的SG函数,,有一丁点儿领悟~~不敢误导大家~就直接上代码了

代码:

/*
S-Nim
Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4975    Accepted Submission(s): 2141


Problem Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:


  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

  The players take turns chosing a heap and removing a positive number of beads from it.

  The first player not able to make a move, loses.


Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:


  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

  If the xor-sum is 0, too bad, you will lose.

  Otherwise, move such that the xor-sum becomes 0. This is always possible.


It is quite easy to convince oneself that this works. Consider these facts:

  The player that takes the last bead wins.

  After the winning player's last move the xor-sum will be 0.

  The xor-sum will change after every move.


Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win. 

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it? 

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
 

Input
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.
 

Output
For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.

 

Sample Input
2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0
 

Sample Output
LWW
WWL
 

*/
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#define LEN 110
#define MAX 10010
using namespace std ;
int s[LEN] , p ,sg[MAX];
void getSG(int k)
{
	bool hash[MAX] ;
	memset(sg,0,sizeof(sg)) ;
	for(int i = 0 ; i < MAX ; ++i)
	{
		memset(hash,false,sizeof(hash)) ;
		for(int j = 0 ; j < k ; ++j)
		{
			if(i-s[j]>=0)
			{
				hash[sg[i-s[j]]] = true ;
			}
		}
		for(int j = 0 ; j < MAX ; ++j)
		{
			if(!hash[j])
			{
				sg[i] = j ;
				break;
			}
		}
	}
}
int main()
{
	int k;
	while(~scanf("%d",&k) && k)
	{
		for(int i = 0 ; i < k ; ++i)
		{
			scanf("%d",&s[i]) ;
		}
		getSG(k);
		int m ; 
		scanf("%d",&m) ;
		string ans ;
		while(m--)
		{
			int temp = 0 , l;
			scanf("%d",&l) ;
			for(int i = 0 ; i < l ; ++i)
			{
				scanf("%d",&p) ; 
				temp = temp^sg[p] ;
			}
			if(temp == 0)
			{
				ans += "L";
			}
			else
			{
				ans += "W";
			}
		}
		cout<<ans<<endl ;
	}
	return 0 ;
}


hdu 1536 S-Nim 博弈论,,求出SG'函数就可以解决

标签:hdu1536   s-nim   sg函数   博弈论   公平组合博弈   

原文地址:http://blog.csdn.net/lionel_d/article/details/43956125

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!