码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3640 Help Me Escape 概率dp

时间:2015-02-27 06:40:00      阅读:131      评论:0      收藏:0      [点我收藏+]

标签:

有一个吸血鬼被困了,有n条路可以逃出去,每条路有一个难度c[],他初始的战斗力是f,对于第i条路,若f > c[i]他花t[i]天就能出去,否则,他就停留一天,同时战斗力增加c[i]然后再选一条路走出去,他走每条路的概率是相同的。问他逃出去的天数的期望。

设dp[i]表示在战斗力为i时逃出去的期望值,那么可推出状态方程 

dp[i] = 1/n * t[j](c[j] > i),dp[i] = 1/n * (1+dp[ i+c[j] ] )( c[j] <= i)。

需要注意的是终态的确定。当f > Max时,这时的期望值为总时间的平均值便是终态了,但是i + c[j]有可能大于Max+1,所以终态应该是Max*2。初始化时就忘乘2了。

还有就是t[i]是整数。




Description

Background

    If thou doest well, shalt thou not be accepted? and if thou doest not well, sin lieth at the door. And unto thee shall be his desire, and thou shalt rule over him. 
    And Cain talked with Abel his brother: and it came to pass, when they were in the field, that Cain rose up against Abel his brother, and slew him. 
    And the LORD said unto Cain, Where is Abel thy brother? And he said, I know not: Am I my brother‘s keeper? 
    And he said, What hast thou done? the voice of thy brother‘s blood crieth unto me from the ground. 
    And now art thou cursed from the earth, which hath opened her mouth to receive thy brother‘s blood from thy hand; 
    When thou tillest the ground, it shall not henceforth yield unto thee her strength; a fugitive and a vagabond shalt thou be in the earth.

—— Bible Chapter 4

Now Cain is unexpectedly trapped in a cave with N paths. Due to LORD‘s punishment, all the paths are zigzag and dangerous. The difficulty of the ith path is ci.

Then we define f as the fighting capacity of Cain. Every day, Cain will be sent to one of the N paths randomly.

Suppose Cain is in front of the ith path. He can successfully take ti days to escape from the cave as long as his fighting capacity f is larger than ci. Otherwise, he has to keep trying day after day. However, if Cain failed to escape, his fighting capacity would increase ci as the result of actual combat. (A kindly reminder: Cain will never died.)

As for ti, we can easily draw a conclusion that ti is closely related to ci. Let‘s use the following function to describe their relationship:

技术分享

After D days, Cain finally escapes from the cave. Please output the expectation of D.

Input

The input consists of several cases. In each case, two positive integers N and f (n ≤ 100, f ≤ 10000) are given in the first line. The second line includes N positive integers ci (ci ≤ 10000, 1 ≤ i ≤ N)

Output

For each case, you should output the expectation(3 digits after the decimal point).

Sample Input

3 1
1 2 3

Sample Output

6.889

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<cstring>
using namespace std;
double dp[1000010];
int b[110];
double a=(1+sqrt(5))*0.5;
int main()
{
    int n,f;
    while(~scanf("%d %d",&n,&f))
    {
        int Max=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&b[i]);
            Max=max(Max,b[i]);
        }
        memset(dp,0,sizeof(dp));
        for(int i=2*Max; i>=f; i--)
        {
           dp[i]=0;
            for(int j=1; j<=n; j++)
            {
                if(i>b[j])dp[i]+=(int)(a*b[j]*b[j]);
                else dp[i]+=(1+dp[i+b[j]]);
            }
            dp[i]/=n;
        }
        printf("%.3lf\n",dp[f]);
    }
    return 0;
}


ZOJ 3640 Help Me Escape 概率dp

标签:

原文地址:http://blog.csdn.net/wweiainn/article/details/43962959

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!