码迷,mamicode.com
首页 > 其他好文 > 详细

【题解】-航电OJ1013 Digital Roots

时间:2015-02-28 01:35:08      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description The digital root of a positive integer is found by
summing the digits of the integer. If the resulting value is a single
digit then that digit is the digital root. If the resulting value
contains two or more digits, those digits are summed and the process
is repeated. This is continued as long as necessary to obtain a single
digit.

For example, consider the positive integer 24. Adding the 2 and the 4
yields a value of 6. Since 6 is a single digit, 6 is the digital root
of 24. Now consider the positive integer 39. Adding the 3 and the 9
yields 12. Since 12 is not a single digit, the process must be
repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the
digital root of 39.

Input The input file will contain a list of positive integers, one per
line. The end of the input will be indicated by an integer value of
zero.

Output For each integer in the input, output its digital root on a
separate line of the output.

Sample Input

24 39 0

Sample Output

6 3

题目考查九余数定理。

#include <stdio.h>
#include <string.h>

char n[10001];

int add_digital(const char* str){
    int result = 0;
    char* pointer = (char*)str;
    while(*pointer){
        result += *pointer - 48;
        pointer++;
    }
    return result;
}

int main(){
    while(scanf("%s",n)){
        if(!strcmp(n,"0")) break;
        int sum = add_digital(n);
        printf("%d\n",(sum - 1)%9 + 1);
    }
    return 0;
}

【题解】-航电OJ1013 Digital Roots

标签:

原文地址:http://blog.csdn.net/gscienty/article/details/43977679

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!