码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2386 Lake Counting 图DFS

时间:2015-03-01 14:30:23      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:dfs      代码   

找出有多少个”水洼”(W的联通块)

Sample Input

10 12
W……..WW.
.WWW…..WWW
….WW…WW.
………WW.
………W..
..W……W..
.W.W…..WW.
W.W.W…..W.
.W.W……W.
..W…….W.

Sample Output

3

解题思路

DFS

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 110;
char pic[maxn][maxn];
int vis[maxn][maxn];
int high,width;
int cnt = 0;
void dfs(int x,int y)
{
    //第x行,第y列
    if(pic[x][y] == ‘.‘ || vis[x][y]) return;
    if(x<0 || y<0 || x>=high || y>=width) return;
    vis[x][y] = 1;
    dfs(x-1,y);dfs(x+1,y);dfs(x,y+1);dfs(x,y-1);
    dfs(x-1,y-1);dfs(x-1,y+1);dfs(x+1,y-1);dfs(x+1,y+1);
}
int main()
{
    scanf("%d%d",&high,&width);
    for(int i = 0 ; i < high ; i ++) scanf("%s",pic[i]);
    for(int i = 0 ; i < high ; i ++) {
        for(int j = 0 ; j < width ; j ++) {
            if(pic[i][j] == ‘.‘) continue;
            if(vis[i][j] == 0) {
                dfs(i,j);
                cnt ++;
            }
        }
    }
    printf("%d\n",cnt);
    return 0;
}

POJ2386 Lake Counting 图DFS

标签:dfs      代码   

原文地址:http://blog.csdn.net/area_52/article/details/44002699

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!