码迷,mamicode.com
首页 > 其他好文 > 详细

poj-2533 Longest Ordered Subsequence 【最长上升子序列】

时间:2015-03-01 18:33:22      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:http://poj.org/problem?id=2533

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 35929   Accepted: 15778

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

求最长上升子序列

#include<stdio.h>
#include<iostream>
#include<math.h>
#include<stdlib.h>
#include<ctype.h>
#include<algorithm>
#include<vector>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>

using namespace std;

int n,p[1010],dp[1010];

int main()
{
	while (scanf("%d", &n) != EOF)
	{
		for (int i = 1; i <= n; i++)
			scanf("%d",&p[i]);
		
		for (int i = 1; i <= n; i++)
		{
			dp[i] = 1;
			for (int j = 1; j < i; j++)
			{
				if (p[i] > p[j])
					dp[i] = max(dp[i],dp[j] + 1);
			}
		}
		int ans = -1;
		for (int i = 1; i <= n; i++)
			ans = max(ans,dp[i]);
		printf("%d\n",ans);
	}
	return 0;
}



poj-2533 Longest Ordered Subsequence 【最长上升子序列】

标签:

原文地址:http://blog.csdn.net/u014427196/article/details/44003711

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!