码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2533 Longest Ordered Subsequence (LIS)

时间:2015-03-02 21:01:07      阅读:189      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 35930   Accepted: 15779

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion



题意:最长上升子序列。

解析:dp递推。



AC代码:

#include <cstdio>
#include <algorithm>
using namespace std;

int n;
int a[1002];
int dp[1002];

void solve(){
    int res = 0;
    for(int i=0; i<n; i++){
        dp[i] = 1;
        for(int j=0; j<i; j++) if(a[j] < a[i]){
            dp[i] = max(dp[i], dp[j] + 1);               //状态转移方程
        }
        res = max(res, dp[i]);
    }
    printf("%d\n", res);
}

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif //sxk

    while(~scanf("%d", &n)){
        for(int i=0; i<n; i++) scanf("%d", &a[i]);

        solve();
    }
}




POJ 2533 Longest Ordered Subsequence (LIS)

标签:

原文地址:http://blog.csdn.net/u013446688/article/details/44022549

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!