标签:
Game with Pearls
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 919 Accepted Submission(s): 353
Problem Description
Tom and Jerry are playing a game with tubes and pearls. The rule of the game is:
1) Tom and Jerry come up together with a number K.
2) Tom provides N tubes. Within each tube, there are several pearls. The number of pearls in each tube is at least 1 and at most N.
3) Jerry puts some more pearls into each tube. The number of pearls put into each tube has to be either 0 or a positive multiple of K. After that Jerry organizes these tubes in the order that the first tube has exact one pearl, the 2nd tube has exact 2 pearls,
…, the Nth tube has exact N pearls.
4) If Jerry succeeds, he wins the game, otherwise Tom wins.
Write a program to determine who wins the game according to a given N, K and initial number of pearls in each tube. If Tom wins the game, output “Tom”, otherwise, output “Jerry”.
Input
The first line contains an integer M (M<=500), then M games follow. For each game, the first line contains 2 integers, N and K (1 <= N <= 100, 1 <= K <= N), and the second line contains N integers presenting the number of pearls in
each tube.
Output
For each game, output a line containing either “Tom” or “Jerry”.
Sample Input
2
5 1
1 2 3 4 5
6 2
1 2 3 4 5 5
Sample Output
Source
Recommend
hujie | We have carefully selected several similar problems for you:
5181 5180 5179 5178 5177
ac代码
#include<stdio.h>
#include<string.h>
int link[1010];
int map[1010][1010],v[1010];
int n;
int dfs(int x)
{
int i;
for(i=1;i<=n;i++)
{
if(map[x][i]==!v[i])
{
v[i]=1;
if(link[i]==-1||dfs(link[i]))
{
link[i]=x;
return 1;
}
}
}
return 0;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int k,i;
scanf("%d%d",&n,&k);
memset(map,0,sizeof(map));
for(i=1;i<=n;i++)
{
int num;
scanf("%d",&num);
while(num<=n)
{
map[num][i]=1;
num+=k;
}
}
memset(link,-1,sizeof(link));
int sum=0;
for(i=1;i<=n;i++)
{
memset(v,0,sizeof(v));
if(dfs(i))
sum++;
}
if(sum==n)
{
printf("Jerry\n");
}
else
printf("Tom\n");
}
}
HDOJ 题目5090 Game with Pearls(二分图)
标签:
原文地址:http://blog.csdn.net/yu_ch_sh/article/details/44036431