码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2844 Coins 多重背包(二进制优化)

时间:2015-03-03 13:44:33      阅读:132      评论:0      收藏:0      [点我收藏+]

标签:


Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8167    Accepted Submission(s): 3327


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn‘t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony‘s coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
8 4
 

Source
 

有n种货币,告诉你每种货币的价值和数量,让你求这些货币能够恰好构成1~m的情况数。
多重背包模板题。
//499MS	1444K
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define M 100007
using namespace std;
int dp[M],val[107],num[107],m;
int n;
void ZeroOnePack(int value)
{
    for(int i=m;i>=value;i--)
        dp[i]=max(dp[i],dp[i-value]+value);
}
void CompletePack(int value)
{
    for(int i=value;i<=m;i++)
        dp[i]=max(dp[i],dp[i-value]+value);
}
void MultiplePack(int count,int value)
{
    if(count*value>m)CompletePack(value);
    else
    {
        int k=1;
        while(k<count)
        {
            ZeroOnePack(k*value);
            count-=k;
            k<<=1;
        }
        ZeroOnePack(count*value);
    }
}
int main()
{
    while(scanf("%d%d",&n,&m),n|m)
    {
        int ans=0,k=0;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            scanf("%d",&val[i]);
        for(int i=1;i<=n;i++)
            scanf("%d",&num[i]);
        for(int i=1;i<=n;i++)
            MultiplePack(num[i],val[i]);
        for(int i=1;i<=m;i++)
            if(dp[i]==i)ans++;
        printf("%d\n",ans);
    }
}


HDU 2844 Coins 多重背包(二进制优化)

标签:

原文地址:http://blog.csdn.net/crescent__moon/article/details/44036139

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!