码迷,mamicode.com
首页 > 其他好文 > 详细

1031. Hello World for U (20)

时间:2015-03-03 18:42:38      阅读:91      评论:0      收藏:0      [点我收藏+]

标签:

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h   d
e    l
l     r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n
1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h      !
e     d
l       l

lowor

//可以用char数组做,本人喜欢用string做,比较简单
#include <iostream>
#include <string>
using namespace std;

int main() {
    string str;
    int n, n1, n2, n3, i, j, start, end;
    while(cin>>str) {
        n = str.length();
        n1 = n3 = (n + 2)/3;
        n2 = n - n1 - n3 + 2;
        start = 0;
        end = n - 1;
        for(i = 0; i < n1; i++) {
            if(i == n1 - 1) {
                for(j=0; j<n2; j++) {
                    cout<<str[start++];
                }
            } else {
                cout<<str[start++];
                for(j=0; j<n2-2; j++) {
                    cout<<" ";
                }
                cout<<str[end--]<<endl;
            }
        }
    }
    return 0;
}


1031. Hello World for U (20)

标签:

原文地址:http://blog.csdn.net/jason_wang1989/article/details/44040431

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!