码迷,mamicode.com
首页 > 其他好文 > 详细

HDU2120Ice_cream's world I(基础并查集)

时间:2015-03-03 22:12:06      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:图论   并查集   

Ice_cream‘s world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 698    Accepted Submission(s): 398


Problem Description
ice_cream‘s world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 

Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
 

Sample Input
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 

Sample Output
3
 

Author
Wiskey
题意:就是图中有几个环。
#include<stdio.h>
const int N = 1015;
int fath[N],n;

void init()
{
    for(int i =0;i<=n;i++)
        fath[i]=i;
}
int findfath(int x)
{
    if(x==fath[x])
        return fath[x];
    fath[x]=findfath(fath[x]);
    return fath[x];
}
int setfath(int x,int y)
{
    x=findfath(x);
    y=findfath(y);
    if(x==y)
        return 1;
    fath[x]= y;
    return 0;
}
int main()
{
    int x,y,m,ans;
    while(scanf("%d%d",&n,&m)>0)
    {
        init();
        ans=0;
        while(m--)
        {
            scanf("%d%d",&x,&y);
            ans+=setfath(x,y);
        }
        printf("%d\n",ans);
    }

}


HDU2120Ice_cream's world I(基础并查集)

标签:图论   并查集   

原文地址:http://blog.csdn.net/u010372095/article/details/44043481

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!