码迷,mamicode.com
首页 > 其他好文 > 详细

几道算法题

时间:2014-06-02 17:36:53      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:des   c   style   class   a   tar   

1.
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
 
 
answer:
 

#include<stdio.h>
#include<string.h>
int main()
{
int t,n,i,j,a,k,l;
int sum[100000+10]={0};
int left,right,min,best;

scanf("%d",&t);
for(k=1;k<=t;k++)
{
scanf("%d",&n);

for(i=1;i<=n;i++) {scanf("%d",&a); sum[i]=sum[i-1]+a;}

left=-1; right=-1;
min=100000001; best=-100000001; //??

for(j=1;j<=n;j++) //以j结尾的子串
{
if(sum[j-1]<min) {min=sum[j-1]; l=j;}
if(sum[j]-min>best)
{
best=sum[j]-min;
left=l;
right=j;
}
}
if(k==t) printf("Case %d:\n%d %d %d\n",k,best,left,right);
else printf("Case %d:\n%d %d %d\n\n",k,best,left,right);
}
return 0;
}

几道算法题,布布扣,bubuko.com

几道算法题

标签:des   c   style   class   a   tar   

原文地址:http://www.cnblogs.com/elliottc/p/3762784.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!