码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 题目2222 Keywords Search(AC自动机)

时间:2015-03-04 09:54:53      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38611    Accepted Submission(s): 12437


Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters ‘a‘-‘z‘, and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 

Output
Print how many keywords are contained in the description.
 

Sample Input
1 5 she he say shr her yasherhs
 

Sample Output
3
 

Author
Wiskey
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  2896 3065 2243 2825 3341 
 ac代码
#include<stdio.h>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
char str[1001000],key[100];
int head,tail;
struct node
{
	node *fail;
	node *next[26];
	int cnt;
	node()
	{
		fail=NULL;
		cnt=0;
		for(int i=0;i<26;i++)
			next[i]=NULL;
	}
}*q[500050];
node *root;
void insert(char *s)
{
	int temp,len,i;
	node *p=root;
	len=strlen(s);
	for(i=0;i<len;i++)
	{
		temp=s[i]-'a';
		if(p->next[temp]==NULL)
			p->next[temp]=new node();
		p=p->next[temp];
	}
	p->cnt++;	
}
void build_ac()
{
	q[tail++]=root;
	while(head!=tail)
	{
		node *p=q[head++];
		node *temp=NULL;
		for(int i=0;i<26;i++)
		{
			if(p->next[i]!=NULL)
			{
				if(p==root)
					p->next[i]->fail=root;
				else
				{
					temp=p->fail;
					while(temp!=NULL)
					{
						if(temp->next[i]!=NULL)
						{
							p->next[i]->fail=temp->next[i];
							break;
						}
						temp=temp->fail;
					}
					if(temp==NULL)
					{
						p->next[i]->fail=root;
					}
				}
				q[tail++]=p->next[i];
			}
		}
	}
}
int query()
{
	int ans=0;
	int len=strlen(str);
	node *p=root,*temp;
	for(int i=0;i<len;i++)
	{
		int x=str[i]-'a';
		while(p->next[x]==NULL&&p!=root)
			p=p->fail;
		p=p->next[x];
		if(p==NULL)
		{
			p=root;
		}
		temp=p;
		while(temp!=root&&temp->cnt!=-1)
		{
			ans+=temp->cnt;
			temp->cnt=-1;
			temp=temp->fail;
		}
	}
	return ans;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,i;
		scanf("%d",&n);
		head=tail=0;
		root=new node();
		for(i=0;i<n;i++)
		{
			scanf("%s",key);
			insert(key);
		}
		build_ac();
		scanf("%s",str);
		printf("%d\n",query());
	}
}


HDOJ 题目2222 Keywords Search(AC自动机)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/44045271

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!