码迷,mamicode.com
首页 > 其他好文 > 详细

Bookshelf 2

时间:2015-03-04 14:28:43      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal ‘excess‘ height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1
大意:求N个数加起来离M最近的值,即背包问题,但是容量不知道,即把比最大的所有可能性都保存下来,从最小开始,如果超过,就是那个值
技术分享
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
  int H[1000005],w[25];
int main()
{


    int n ,m, sum;
    sum = 0;
    while(~scanf("%d%d", &n, &m)){
            memset(w, 0, sizeof(w));

        for(int i = 1; i <= n; i++){
            scanf("%d", &w[i]);
            sum += w[i];
        }
        for(int i = 0; i <=sum ;i++)
            H[i] = 0;


        for(int i = 1;i <= n; i++){
            for(int j = sum ; j >= w[i]; j--){
                 H[j] = max(H[j], H[j-w[i]] + w[i] );
            }
        }
        for(int i = 1; i <= sum; i++){
            if(H[i] >= m){
                printf("%d\n", H[i] - m);
                break;
            }
        }
    }
        return 0;
}
View Code

 

 

Bookshelf 2

标签:

原文地址:http://www.cnblogs.com/zero-begin/p/4313200.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!