码迷,mamicode.com
首页 > 其他好文 > 详细

Charm Bracelet

时间:2015-03-04 14:28:54      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:

Description

Bessie has gone to the mall‘s jewelry store and spies a charm bracelet. Of course, she‘d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability‘ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

大意:在一共M大的背包里面放N件东西,计算这N件东西的最大价值,很基础的背包问题,即在第二个for循环中从背包的最大容量开始,因为背包可以有剩余,然后减少,用递归,dp[j] = max(dp[j],dp[j-w[i]]+v[i]);
技术分享
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
const int maxn = 222222;
int w[maxn],v[maxn],dp[maxn];
int main(){
    int n,m;
    memset(dp,0,sizeof(dp));
    scanf("%d%d",&n,&m);
    for(int i = 1; i <= n ; i++)
        scanf("%d%d",&w[i],&v[i]);
        for(int i = 1; i <= n ; i++){
                for(int j = m; j >= w[i];j--){
                        dp[j] = max(dp[j],dp[j-w[i]]+v[i]);
                }
        }
        printf("%d",dp[m]);
}
View Code

 




Charm Bracelet

标签:

原文地址:http://www.cnblogs.com/zero-begin/p/4313189.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!