码迷,mamicode.com
首页 > 其他好文 > 详细

Y2K Accounting Bug

时间:2015-03-04 14:30:26      阅读:126      评论:0      收藏:0      [点我收藏+]

标签:

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit

Source

 
大意:这题比较坑..难在读题,s为每个月固定的盈利,d为每个月固定的赤字,没五个月调查一次收支,每次都要为赤字,1-5,2-6,3-7,4-8,5-9,6-10,7-11,8-12。一共八次。
只要使得赤字更多的被应用
ssssd   ssssd    ss
sssdd   sssdd    ss
ssddd   ssddd    ss
sdddd   sdddd    ds
ddddd  ddddd    dd
所以只要使得每五个月都赤字,最后输出总盈利减去总赤字就行。
技术分享
#include<cstdio>
#include<cstring>
using namespace std;
int main(){
    int s,d,temp ;
    while(~scanf("%d%d",&s,&d)){
            if((4*s-d)<0)
            temp = 10*s-2*d;
        else if((3*s-2*d)<0)
            temp = 8*s-4*d;
        else if((2*s-3*d)<0)
            temp = 6*s-6*d;
        else if((s-4*d)<0)
            temp = 3*s-9*d;
        else temp = -1;
        if(temp>=0)
            printf("%d\n",temp);
        else printf("Deficit\n");
    }
    return 0;
}
View Code

 

Y2K Accounting Bug

标签:

原文地址:http://www.cnblogs.com/zero-begin/p/4313168.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!