码迷,mamicode.com
首页 > 其他好文 > 详细

uva 757 Gone Fishing (贪心)

时间:2015-03-04 22:49:22      阅读:215      评论:0      收藏:0      [点我收藏+]

标签:acm   c语言   uva   

                          uva 757 Gone Fishing


John is going on a fishing trip. He has h hours available ( 技术分享), and there are n lakes in the area ( 技术分享) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each 技术分享, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti ( 技术分享). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4.


To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi ( 技术分享), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di ( 技术分享). If the number of fish expected to be caught in an interval is less than or equal to di, there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch.


Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

Input 

You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi ( 技术分享), then a line of n integers di ( 技术分享), and finally, a line of n - 1 integers ti ( 技术分享). Input is terminated by a case in which n = 0.

Output 

For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected. If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.

Sample Input 

2
1
10 1
2 5
2
4
4
10 15 20 17
0 3 4 3
1 2 3
4
4
10 15 50 30
0 3 4 3
1 2 3
0

Sample Output 

45, 5
Number of fish expected: 31

240, 0, 0, 0
Number of fish expected: 480

115, 10, 50, 35
Number of fish expected: 724



题目大意:

每组样例包括5各部分:

1)鱼塘数 n

2)总时间 h(小时)

3)n 个鱼塘,每个鱼塘中初始鱼的产量(每5分钟可以钓上的鱼的数量)

4)n 个鱼塘,每个鱼塘鱼的损耗速度(每在该鱼塘钓鱼5分钟,鱼的产量减少的数量)

5)n 个鱼塘之间的路程的耗时(单位为5分钟)

要求在总时间 h 内可以钓上的最多的鱼的数量,和在每一个鱼塘停留的时间。当到达下一个鱼塘时,不能返回上一个鱼塘。

解题思路:先要对鱼塘之间路程的耗时进行处理,要将其转变为从第一个鱼塘到第 i 个鱼塘所需的时间。

枚举只在前 i 个鱼塘钓鱼的 n 种情况,这样  只在前 i 个鱼塘钓鱼的钓鱼时间 = 总时间 - 第一个鱼塘到第 i 个鱼塘所需时间,然后在前 i 个鱼塘中找出当前鱼产量最多的鱼塘,在此钓鱼,然后重复之前的过程,直到前 i 个鱼塘无鱼可钓或者时间耗尽。这样,n 种情况中的最大值,就是可以钓起的最多鱼的数量。



#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int n, h, f[250], d[250], t[250], ans, rec[250], recA[250], temp[250];
int find(int x) {
	int num = 0, id;
	for (int i = 0; i <= x; i++) {
		if (temp[i] > num) {
			num = temp[i];
			id = i;
		}	
	}
	if (num) {
		return id;
	}
	else return -1;
}
int main() {
	int flag = 0;
	while (scanf("%d", &n) == 1, n) {
		if (flag) printf("\n");
		flag = 1;
		int H;
		scanf("%d", &H);
		h = H * 12;
		for (int i = 0; i < n; i++) {
			scanf("%d", &f[i]);
		}
		for (int i = 0; i < n; i++) {
			scanf("%d", &d[i]);
		}
		t[0] = 0;
		for (int i = 1; i < n; i++) {
			scanf("%d", &t[i]);
			t[i] += t[i - 1];
		}
		memset(recA, 0, sizeof(recA));
		ans = 0;	
		for (int i = 0; i < n; i++) { //枚举n种情况:从第一个鱼塘到第i个鱼塘
			int time = h - t[i], sum = 0;
			if (time <= 0) break;
			memcpy(temp, f, sizeof(f));
			memset(rec, 0, sizeof(rec));
			while (time) {
				int id = find(i); //find找出前i个鱼塘中鱼最多的鱼塘
				if (id < 0) break;
				sum += temp[id];
				temp[id] -=	d[id];	
				time--;
				rec[id]++;
			}
			if (time > 0) { //当前i个鱼塘都无鱼可钓,且还有剩余时间,留在第一个鱼塘
				rec[0] += time;
			}
			if (sum > ans) {
				ans = sum;
				memcpy(recA, rec, sizeof(rec));
			}
		}
		if (ans) {
			printf("%d", recA[0] * 5);
		}
		else printf("%d", h * 5); //当无鱼可钓的时候也要停留在第一个鱼塘,样例会卡这里
		for (int i = 1; i < n; i++) {
			printf(", %d", recA[i] * 5);
		}
		printf("\nNumber of fish expected: %d\n", ans);
	}	
	return 0;
}



uva 757 Gone Fishing (贪心)

标签:acm   c语言   uva   

原文地址:http://blog.csdn.net/llx523113241/article/details/44064615

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!