码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3070-Fibonacci(矩阵快速幂求斐波那契数列)

时间:2015-03-04 22:50:39      阅读:261      评论:0      收藏:0      [点我收藏+]

标签:

Fibonacci
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn ? 1 + Fn ? 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

技术分享.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number ?1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

技术分享.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

技术分享.


题意:题意:求第n个Fibonacci数mod(m)的结果,当n=-1时,break。其中n(where 0 ≤ n ≤ 1,000,000,000) ,m=10000;

思路:常规方法肯定超时,这道题学会了用矩阵快速幂求斐波那契。如下图:

技术分享

A = F(n - 1), B = F(N - 2),这样使构造矩阵技术分享的n次幂乘以初始矩阵技术分享得到的结果就是技术分享


#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <map>
#include <queue>
using namespace std;
const int inf=0x3f3f3f3f;
const int mod=10000;
struct node
{
    int mp[3][3];
}init,res;
struct node Mult(struct node x,struct node y)
{
    struct node tmp;
    int i,j,k;
    for(i=0;i<2;i++)
        for(j=0;j<2;j++)
        {
            tmp.mp[i][j]=0;
            for(k=0;k<2;k++)
            {
                tmp.mp[i][j]=(tmp.mp[i][j]+x.mp[i][k]*y.mp[k][j])%mod;
            }
        }
    return tmp;
}
struct node expo(struct node x, int k)
{
    int i,j;
    struct node tmp;
    for(i=0;i<2;i++)
        for(j=0;j<2;j++)
        {
            if(i==j)
                tmp.mp[i][j]=1;
            else
                tmp.mp[i][j]=0;
        }
    while(k)
    {
        if(k&1) tmp=Mult(tmp,x);
        x=Mult(x,x);
        k>>=1;
    }
    return tmp;
}
int main()
{
    int k;
    while(~scanf("%d",&k))
    {
        if(k==-1) break;
        init.mp[0][0]=1;
        init.mp[0][1]=1;
        init.mp[1][0]=1;
        init.mp[1][1]=0;
        res=expo(init,k);
        printf("%d\n",res.mp[0][1]);
    }
    return 0;
}


POJ 3070-Fibonacci(矩阵快速幂求斐波那契数列)

标签:

原文地址:http://blog.csdn.net/u013486414/article/details/44064467

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!