码迷,mamicode.com
首页 > 其他好文 > 详细

PAT (Basic Level) 1004. 成绩排名 (20)

时间:2015-03-06 18:53:22      阅读:138      评论:0      收藏:0      [点我收藏+]

标签:

读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:每个测试输入包含1个测试用例,格式为

  第1行:正整数n
  第2行:第1个学生的姓名 学号 成绩
  第3行:第2个学生的姓名 学号 成绩
  ... ... ...
  第n+1行:第n个学生的姓名 学号 成绩

其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:

Mike CS991301
Joe Math990112

 

#include<iostream>
#include<string>
using namespace std;
class Student{
public:
    string name;
    string sid;
    int score;
};
int main(){
    int n,first=0,last=0;
    cin>>n;
    Student *stu=new Student[n];
    for(int i=0;i<n;i++){
        cin>>stu[i].name>>stu[i].sid>>stu[i].score;    
    }
    if(n==1){
        cout<<stu[0].name<<" "<<stu[0].sid<<endl;
        cout<<stu[0].name<<" "<<stu[0].sid<<endl;
    }else{
        for(int i=1;i<n;i++){
            if(stu[first].score<stu[i].score){
                first=i;
            }
            if(stu[last].score>stu[i].score){
                last=i;
            }
        }
        cout<<stu[first].name<<" "<<stu[first].sid<<endl;
        cout<<stu[last].name<<" "<<stu[last].sid<<endl;
    
    }

    delete [] stu;
    return 0;
}

技术分享

PAT (Basic Level) 1004. 成绩排名 (20)

标签:

原文地址:http://www.cnblogs.com/Zengineer/p/4318857.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!