码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3065 病毒侵袭持续中 (AC自动机)

时间:2015-03-06 20:49:42      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:hdu   ac自动机   


病毒侵袭持续中

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7477    Accepted Submission(s): 2595

Problem Description

小t非常感谢大家帮忙解决了他的上一个问题。然而病毒侵袭持续中。在小t的不懈努力下,他发现了网路中的“万恶之源”。这是一个庞大的病毒网站,他有着好多好多的病毒,但是这个网站包含的病毒很奇怪,这些病毒的特征码很短,而且只包含“英文大写字符”。当然小t好想好想为民除害,但是小t从来不打没有准备的战争。知己知彼,百战不殆,小t首先要做的是知道这个病毒网站特征:包含多少不同的病毒,每种病毒出现了多少次。大家能再帮帮他吗?
 

Input
第一行,一个整数N(1<=N<=1000),表示病毒特征码的个数。
接下来N行,每行表示一个病毒特征码,特征码字符串长度在1—50之间,并且只包含“英文大写字符”。任意两个病毒特征码,不会完全相同。
在这之后一行,表示“万恶之源”网站源码,源码字符串长度在2000000之内。字符串中字符都是ASCII码可见字符(不包括回车)。
 

Output
按以下格式每行一个,输出每个病毒出现次数。未出现的病毒不需要输出。
病毒特征码: 出现次数
冒号后有一个空格,按病毒特征码的输入顺序进行输出。
 

Sample Input
3 AA BB CC ooxxCC%dAAAoen....END
 

Sample Output
AA: 2 CC: 1
Hint
Hit: 题目描述中没有被提及的所有情况都应该进行考虑。比如两个病毒特征码可能有相互包含或者有重叠的特征码段。 计数策略也可一定程度上从Sample中推测。
 

Source
 
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3065

题目分析:裸的AC自动机,忽视了只含大写字母,MLE了,注意是多组数据,存一下每个单词和对应的出现次数


#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
int const MAX = 2000005;
char word[1005][55], text[MAX];
int cnt[1005];

struct node 
{
    int id;
    bool end;           
    node *next[26];   
    node *fail;         
    node()             
    {
        id = -1;
        end = false;
        memset(next, NULL, sizeof(next));
        fail = NULL;
    }
};

void Insert(node *p, char *s, int id)
{
    for(int i = 0; s[i] != '\0'; i++)
    {
        int idx = s[i] - 'A';
        if(p -> next[idx] == NULL)
            p -> next[idx] = new node();
        p = p -> next[idx];
    }
    p -> end = true; 
    p -> id = id;
}

void AC_Automation(node *root)
{   
    queue <node*> q; 
    q.push(root);
    while(!q.empty())
    {
        node *p = q.front();
        q.pop();
        for(int i = 0; i < 26; i++)
        {
            if(p -> next[i])  
            {
                if(p == root)
                    p -> next[i] -> fail = root;
                else
                    p -> next[i] -> fail = p -> fail -> next[i];
                q.push(p -> next[i]);
            }
            else
            {
                if(p == root)
                    p -> next[i] = root;
                else
                    p -> next[i] = p -> fail -> next[i];
            }
        }
    }
}

bool Query(node *root)
{
    bool flag = false;
    int len = strlen(text);
    node *p = root;
    for(int i = 0; i < len; i++)
    {
        int idx = text[i] - 'A';
        if(idx < 0 || idx > 25)
        {
            p = root;
            continue;
        }
        while(!p -> next[idx] && p != root)
            p = p -> fail;
        p = p -> next[idx];
        if(!p)     
        {
            p = root;
            continue;
        }
        node *tmp = p;
        while(tmp != root)
        {
            if(tmp -> end)
            {
                flag = true;
                cnt[tmp -> id]++;
            }
            else
                break;
            tmp = tmp -> fail;
        }
    }
    return flag;
}

int main()
{
    int n;
    while(scanf("%d", &n) != EOF)
    {
        memset(cnt, 0, sizeof(cnt));
        node *root = new node();
        for(int i = 0; i < n; i++)
        {
            scanf("%s", word[i]);
            Insert(root, word[i], i);
        }
        AC_Automation(root);
        getchar();
        gets(text);
        if(Query(root))
            for(int i = 0; i < n; i++)
                if(cnt[i])
                    printf("%s: %d\n", word[i], cnt[i]);
    }
}


HDU 3065 病毒侵袭持续中 (AC自动机)

标签:hdu   ac自动机   

原文地址:http://blog.csdn.net/tc_to_top/article/details/44103339

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!