码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2240

时间:2014-06-01 17:26:29      阅读:369      评论:0      收藏:0      [点我收藏+]

标签:des   c   style   class   blog   code   

Arbitrage
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14832   Accepted: 6255

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

Source

简单floyd
#include<cstdio>
#include<cstring>
using namespace std;
int n,m;
double map[35][35];
char a[50][50];
int locate(char *ss){       //确定节点编号 
    for(int i=1;i<=n;i++){
        if(strcmp(ss,a[i])==0)
            return i;
    }
}
int main(){
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int cas=1;
    while(scanf("%d",&n)!=EOF&&n){
        for(int i=1;i<=n;i++)
            scanf("%s",a[i]);
        scanf("%d",&m);
        memset(map,0,sizeof(map));
        for(int i=1;i<=m;i++){
            char s1[50],s2[50];
            double s;
            scanf("%s%lf%s",s1,&s,s2);
            map[locate(s1)][locate(s2)]=s;
        }
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                for(int k=1;k<=n;k++)
                    if(map[i][j]<map[i][k]*map[k][j])
                        map[i][j]=map[i][k]*map[k][j];
        int i;
        for(i=1;i<=n;i++)
            if(map[i][i]>1.0)
                break;
        if(i<=n)
            printf("Case %d: Yes\n",cas);
        else
            printf("Case %d: No\n",cas);
        cas++;
    }
    return 0;
}


poj 2240,布布扣,bubuko.com

poj 2240

标签:des   c   style   class   blog   code   

原文地址:http://blog.csdn.net/my_acm/article/details/27960765

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!