码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 题目2846 Repository(字典树)

时间:2015-03-07 17:13:20      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:

Repository

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2656    Accepted Submission(s): 1040


Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
 

Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it‘s length isn‘t beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
 

Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.
 

Sample Input
20 ad ae af ag ah ai aj ak al ads add ade adf adg adh adi adj adk adl aes 5 b a d ad s
 

Sample Output
0 20 11 11 2
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:  2852 2847 2850 2851 2848 
 
ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct s
{
	struct s * child[26];
	int cnt,id;
}node,*Node;
Node root;
void insert(char *s,int id)
{
	Node cur,newnode;
	int i,now,len;
	len=strlen(s);
	cur=root;
	for(i=0;i<len;i++)
	{
		now=s[i]-'a';
		if(cur->child[now]!=NULL)
		{
			cur=cur->child[now];
		}
		else
		{
			newnode=(Node)calloc(1,sizeof(node));
			cur->child[now]=newnode;
			cur=cur->child[now];
			cur->cnt=0;
			cur->id=-1;
		}
		if(cur->id!=id)
		{
			cur->cnt++;
			cur->id=id;
		}
	}
}
void seach(char *s)
{
	Node cur;
	cur=root;
	int i,len=strlen(s);
	for(i=0;i<len;i++)
	{
		int now=s[i]-'a';
		if(cur->child[now]==NULL)
			break;
		cur=cur->child[now];
	}
	if(i<len)
		printf("0\n");
	else
		printf("%d\n",cur->cnt);
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int i,j;
		char str[21];
		root=(Node)calloc(1,sizeof(node));
		for(i=0;i<n;i++)
		{
			scanf("%s",str);
			int len=strlen(str);
			for(j=0;j<len;j++)
				insert(str+j,i);
		}
		int m;
		scanf("%d",&m);
		while(m--)
		{
			scanf("%s",str);
			seach(str);
		}
	}
}


HDOJ 题目2846 Repository(字典树)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/44117463

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!