码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 147 Dollars

时间:2015-03-07 19:53:59      阅读:113      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

Status

Description

技术分享

New Zealand currency consists of $100, $50, $20, $10, and $5 notes and $2, $1, 50c, 20c, 10c and 5c coins. Write a program that will determine, for any given amount, in how many ways that amount may be made up. Changing the order of listing does not increase the count. Thus 20c may be made up in 4 ways: 1 技术分享 20c, 2 技术分享 10c, 10c+2 技术分享 5c, and 4 技术分享 5c.

Input

Input will consist of a series of real numbers no greater than $300.00 each on a separate line. Each amount will be valid, that is will be a multiple of 5c. The file will be terminated by a line containing zero (0.00).

Output

Output will consist of a line for each of the amounts in the input, each line consisting of the amount of money (with two decimal places and right justified in a field of width 6), followed by the number of ways in which that amount may be made up, right justified in a field of width 17.

Sample input

0.20
2.00
0.00

Sample output

  0.20                4
  2.00              293
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <ctype.h>
#include <iostream>
#include <string>
#include <algorithm>

using namespace std;
long long a[6001]; //记录每种钱的组合数目
int b[]={1,2,4,10,20,40,100,200,400,1000,2000};

int main()
{
	for(int i=0; i<=6000; i++)
		a[i]=1; //仅由5分构成的话
	for(int i=1; i<11; i++) //从下标1开始,0下标已被跳过
	{
		for(int j=b[i]; j<=6000; j++) //枚举可使用第i类货币每一种可能
		{
			a[j]=a[j]+a[j-b[i]]; //当前的种类数+前i-1种货币构成j-b[i]的方法数
		}
	}
	double dd;
	while(scanf("%lf", &dd)!=EOF)
	{
		if(dd==0.00)
			break;
		int n=(int)(dd*20.0);
		printf("%6.2lf%17lld\n", dd, a[n] );
	}
	return 0;
}

 

UVA 147 Dollars

标签:

原文地址:http://www.cnblogs.com/yspworld/p/4320787.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!