码迷,mamicode.com
首页 > 其他好文 > 详细

HDU5182 PM2.5

时间:2015-03-07 22:48:39      阅读:274      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description

Nowadays we use content of PM2.5 to discribe the quality of air. The lower content of PM2.5 one city have, the better quality of air it have. So we sort the cities according to the content of PM2.5 in asending order.

Sometimes one city’s rank may raise, however the content of PM2.5 of this city may raise too. It means that the quality of this city is not promoted. So this way of sort is not rational. In order to make it reasonable, we come up with a new way to sort the cityes. We order this cities through the diffrence between twice measurement of content of PM2.5 (first measurement – second measurement) in descending order, if there are ties, order them by the second measurement in asending order , if also tie, order them according to the input order.

Input

Multi test cases (about 100), every case contains an integer n which represents there are n cities to be sorted in the first line.
Cities are numbered through 0 to n?1.
In the next n lines each line contains two integers which represent the first and second measurement of content of PM2.5
The ith line describes the information of city i?1
Please process to the end of file.

[Technical Specification]
all integers are in the range [1,100]

Output

For each case, output the cities’ id in one line according to their order.

Sample Input

2
100 1
1 2
3
100 50
3 4
1 2

Sample Output

0 1
0 2 1

思路

大水题

代码

#include <cstdio>
#include <algorithm>
using namespace std;
struct p {
    int num;
    int first;
    int second;
    int cha;
};
p s[110];
bool cmp(p a,p b)
{
    if(a.first-a.second != b.first-b.second) {
        return a.first-a.second > b.first-b.second;
    }
    if(a.second != b.second)
    return a.second < b.second;
    return a.num < b.num;
}
int main()
{
    int n;
    while(scanf("%d",&n) != EOF) {
        for(int i = 0 ; i < n ; i ++) {
            s[i].num = i;
            scanf("%d%d",&s[i].first,&s[i].second);
        }
        sort(s,s+n,cmp);
        for(int i = 0 ; i < n-1 ; i ++) printf("%d ",s[i].num);
        printf("%d\n",s[n-1].num);
    }
    return 0;
}

HDU5182 PM2.5

标签:

原文地址:http://blog.csdn.net/area_52/article/details/44120969

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!