码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3273 Monthly Expense

时间:2015-03-08 15:44:07      阅读:132      评论:0      收藏:0      [点我收藏+]

标签:

Monthly Expense
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 16076   Accepted: 6408

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ‘s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M 
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.


#include <iostream>
#include <stdio.h>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#define N 200009
using namespace std;

int n,m;
int a[N];

int fun(int mm)
{
    int num=1;//注意,初始时候把全部天数作为一组
    int sum=0;

    for(int i=1;i<=n;i++)
    {
        if(sum+a[i]<=mm)
        sum+=a[i];
        else
        {
            sum=a[i];
            num++;
        }
    }
    if(num>m)
    return 1;
    else
    return 0;
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        int mmax=0;
        int ss=0;

        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);

            ss+=a[i];
            if(mmax<a[i])
            mmax=a[i];
        }

        int le=mmax,ri=ss;
        int mid;

        while(le<ri)
        {
            mid=(le+ri)/2;
            if(fun(mid))
            le=mid+1;
            else
            ri=mid-1;
        }

    cout<<le<<endl;

    }
    return 0;
}






POJ 3273 Monthly Expense

标签:

原文地址:http://blog.csdn.net/wust_zjx/article/details/44133143

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!