码迷,mamicode.com
首页 > 其他好文 > 详细

Common Subsequence

时间:2015-03-08 17:06:45      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0
大意最长公共子序列
技术分享
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[1000][1000];
int main(){
    char s1[1000],s2[1000];
    char t;
    while(~scanf("%s%s",s1,s2)){
            memset(dp,0,sizeof(dp));
       int    n1 = strlen(s1);
       int    n2 = strlen(s2);
          for(int i = 1 ; i <= n1;i++){
            for(int j = 1;j <= n2; j++){
                if(s1[i-1] == s2[j-1]){
                    dp[i][j]=dp[i-1][j-1]+1;
                }
                else dp[i][j] = max(dp[i-1][j],dp[i][j-1]);
            }
          }
          printf("%d\n",dp[n1][n2]);
    }
    return 0;
}
View Code

 

 

Common Subsequence

标签:

原文地址:http://www.cnblogs.com/zero-begin/p/4321833.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!