标签:hdu3661 贪心 assignments
Assignments
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1637 Accepted Submission(s): 759
Problem Description
In a factory, there are N workers to finish two types of tasks (A and B). Each type has N tasks. Each task of type A needs xi time to finish, and each task of type B needs yj time to finish, now, you, as the boss of the factory, need
to make an assignment, which makes sure that every worker could get two tasks, one in type A and one in type B, and, what‘s more, every worker should have task to work with and every task has to be assigned. However, you need to pay extra money to workers
who work over the standard working hours, according to the company‘s rule. The calculation method is described as follow: if someone’ working hour t is more than the standard working hour T, you should pay t-T to him. As a thrifty boss, you want know the minimum
total of overtime pay.
Input
There are multiple test cases, in each test case there are 3 lines. First line there are two positive Integers, N (N<=1000) and T (T<=1000), indicating N workers, N task-A and N task-B, standard working hour T. Each of the next two
lines has N positive Integers; the first line indicates the needed time for task A1, A2…An (Ai<=1000), and the second line is for B1, B2…Bn (Bi<=1000).
Output
For each test case output the minimum Overtime wages by an integer in one line.
Sample Input
Sample Output
Assignments
将a、b两种任务分别存在两个数组中,然后分别排序,一个从小到大另一个从大到小排。再从1到就算完即可。因为我们可以假设当先取a中最小值时,将其与b中的最大值匹配一定不会亏,因为若与b中最大值匹配时间超过了T,这a中任何一个与之匹配都会超,若未超过,那自然最好(不用考虑若此时b中最大与a中次小匹配也不超的情况,因为这种情况下a中次小在a中最小与b中最大匹配完之后可以b和b中的次大完美匹配)。
代码:
#include <stdio.h>
#include <algorithm>
#define MAX 1100
using namespace std ;
bool cmp(const int a , const int b)
{
return a>b ;
}
int a[MAX] , b[MAX] ;
int main()
{
int n , t ;
while(~scanf("%d%d",&n,&t))
{
for(int i = 0 ; i < n ; ++i)
{
scanf("%d",&a[i]) ;
}
for(int i = 0 ; i < n ; ++i)
{
scanf("%d",&b[i]) ;
}
sort(a,a+n);
sort(b,b+n,cmp) ;
int sum = 0 ;
for(int i = 0 ; i < n ; ++i)
{
if(a[i]+b[i]>t)
{
sum += a[i]+b[i]-t ;
}
}
printf("%d\n",sum) ;
}
return 0 ;
}
与君共勉hdu 3661 Assignments 贪心
标签:hdu3661 贪心 assignments
原文地址:http://blog.csdn.net/lionel_d/article/details/44134279