码迷,mamicode.com
首页 > 其他好文 > 详细

(hdu step 6.1.2)Eddy's picture(在只给出二维坐标点的情况下,求让n个点连通的最小费用)

时间:2015-03-09 20:56:12      阅读:136      评论:0      收藏:0      [点我收藏+]

标签:

题目:

Eddy‘s picture

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 172 Accepted Submission(s): 126
 
Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends ‘s view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 
Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. 

Input contains multiple test cases. Process to the end of file.
 
Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. 
 
Sample Input
3
1.0 1.0
2.0 2.0
2.0 4.0
 
Sample Output
3.41
 
Author
eddy
 
 
Recommend
JGShining
 


题目分析:

               使用kruscal来求最小生成树,简单题。这道题和上一道题比较的特点就在于:

1)有一维坐标点变成二维坐标点。

struct Point{
double x;
double y;
}points[maxn];

2)点与点之间的距离不再直接给出,而需要你自己算。

edges[cnt++].weight = get_distance(points[i],points[j]);//这是点与点之间的距离不再是直接给出而是需要你自己算



代码如下:

/*
 * b.cpp
 *
 *  Created on: 2015年3月9日
 *      Author: Administrator
 */

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>


using namespace std;

const int maxn = 101;

struct Point{
	double x;
	double y;
}points[maxn];

struct Edge{
	int begin;
	int end;
	double weight;
}edges[maxn*maxn];

int father[maxn];

int find(int a){
	if(a == father[a]){
		return a;
	}

	return father[a] = find(father[a]);
}



double kruscal(int count){
	int i;

	for(i = 1 ; i < maxn ; ++i){
		father[i] = i;
	}

	double sum = 0;

	for(i = 1 ; i <= count ; ++i){
		int fx = find(edges[i].begin);
		int fy = find(edges[i].end);

		if(fx != fy){
			father[fx] = fy;
			sum += edges[i].weight;
		}
	}

	return sum;
}

double get_distance(Point a,Point b){
	return sqrt(pow(b.x-a.x,2)+pow(b.y-a.y,2));
}

bool cmp(Edge a,Edge b){
	return a.weight < b.weight;
}

int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		int i;
		for(i = 1 ; i <= n ; ++i){
			scanf("%lf%lf",&points[i].x,&points[i].y);
		}

		int cnt = 1;
		int j;
		for(i = 1 ; i <= n ; ++i){//枚举所有能形成边的情况
			for(j = i+1 ; j <= n ; ++j){
				edges[cnt].begin = i;
				edges[cnt].end = j;
				edges[cnt++].weight = get_distance(points[i],points[j]);//这是点与点之间的距离不再是直接给出而是需要你自己算
			}
		}

		cnt -= 1;

		sort(edges+1,edges+1+cnt,cmp);

		printf("%.2lf\n",kruscal(cnt));

	}

	return 0;
}














(hdu step 6.1.2)Eddy's picture(在只给出二维坐标点的情况下,求让n个点连通的最小费用)

标签:

原文地址:http://blog.csdn.net/hjd_love_zzt/article/details/44159659

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!