码迷,mamicode.com
首页 > 其他好文 > 详细

(简单母函数模板)hdu 1028 Ignatius and the Princess III

时间:2015-03-11 14:53:55      阅读:131      评论:0      收藏:0      [点我收藏+]

标签:母函数

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14405    Accepted Submission(s): 10142


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
4 10 20
 

Sample Output
5 42 627
 

Author
Ignatius.L

考察知识点;母函数模板
//母函数模板--整数拆分--无穷多个硬币的情况 
//事实证明:memset函数 不能为数组进行除了0,-1 外的赋值1 
#include<stdio.h>
#include<string.h>
int c1[125],c2[125];
int main()
{
	int n;
	int i,j,k;
	while(~scanf("%d",&n))
	{
		for(i=0;i<=n;++i)
		{
			c1[i]=1;
			c2[i]=0;
		}
		for(i=2;i<=n;++i)//i个表达式 
		{
			for(j=0;j<=n;++j)//前面i个表达式相乘的结果中的第j项 
			{
				for(k=0;k+j<=n;k+=i)//指数 
				{
					c2[k+j]+=c1[j];
				}
			}
			for(j=0;j<=n;++j)
			c1[j]=c2[j],c2[j]=0;
		}
		printf("%d\n",c1[n]);
	}
	return 0;
}


(简单母函数模板)hdu 1028 Ignatius and the Princess III

标签:母函数

原文地址:http://blog.csdn.net/ice_alone/article/details/44197547

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!