码迷,mamicode.com
首页 > 其他好文 > 详细

(hdu 简单题 128道)Lowest Bit(求一个数的二进制的最后一个非零位对应的十进制数)

时间:2015-03-11 17:11:56      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:

题目:

Lowest Bit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8722    Accepted Submission(s): 6428


Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
 

Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.
 

Output
For each A in the input, output a line containing only its lowest bit.
 

Sample Input
26 88 0
 

Sample Output
2 8
 

Author
SHI, Xiaohan
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:  1200 1201 1008 1004 1106 


题目分析:

                简单题。在将10进制数转换成2进制数的过程中不断地判断当前位是否是非零位即可。


相应的知识点:

在这时候可能需要回顾一下10进制转2进制的过程:

技术分享



代码如下:

/*
 * d.cpp
 *
 *  Created on: 2015年3月11日
 *      Author: Administrator
 */


#include <iostream>
#include <cstdio>
#include <cmath>


using namespace std;


int main(){
	int n;
	while(scanf("%d",&n)!=EOF,n){

		int t = 0;
		while(n%2 == 0){
			t++;
			n /= 2;
		}

		printf("%d\n",(int)pow(2+0.0,t));
	}

	return 0;
}




 


(hdu 简单题 128道)Lowest Bit(求一个数的二进制的最后一个非零位对应的十进制数)

标签:

原文地址:http://blog.csdn.net/hjd_love_zzt/article/details/44201135

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!