码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1141 Factstone Benchmark 数论水题,,阶乘用斯特林公式

时间:2015-03-11 17:24:45      阅读:189      评论:0      收藏:0      [点我收藏+]

标签:hdu1141   factstone benchmark   acm   数论   

Factstone Benchmark

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1760    Accepted Submission(s): 973


Problem Description
Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.)
Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word.

Given a year 1960 ≤ y ≤ 2160, what will be the Factstone rating of Amtel‘s most recently released chip?

There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case. For each test case, output a line giving the Factstone rating.
 

Sample Input
1960 1981 0
 

Sample Output
3 8

不知道为什么,就是感觉数据很水。。我感觉我写的代码应该过不了的,结果过了
代码:
#include <stdio.h>
#include <math.h>
#define MAX 210
#define PI 3.14159265358979323846
#define E 2.7182818284590452354
int main()
{
	int ans[MAX] ;
	int j = 1 ;
	for(int i = 0; i < MAX ; ++i)
	{
		for( ; ; ++j)
		{
			if(0.5*log10(2*PI*j)+j*log10(j/E)>pow(2.0,i/10+2)*log10(2.0))
			{
				ans[i] = j-1 ;
				break ;
			}
		}
	}
	int year ;
	while(~scanf("%d",&year) && year)
	{
		printf("%d\n",ans[year-1960]);
	}
	return 0 ;
}

与君共勉

hdu 1141 Factstone Benchmark 数论水题,,阶乘用斯特林公式

标签:hdu1141   factstone benchmark   acm   数论   

原文地址:http://blog.csdn.net/lionel_d/article/details/44199403

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!